Bug 59994 - Laptop resume does not respect clock's UTC=false
Laptop resume does not respect clock's UTC=false
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
: 7062 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-18 13:36 EST by Matthew Saltzman
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-18 13:36:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2002-02-18 13:36:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
On resume from suspend-to-memory (at least on my Dell CPxJ and C610),
the clock will sometimes be set to five hours behind the hardware clock. 
Coincidentally, this is the difference between my timezone and UTC.  My hardware
clock is local time, so the system clock ends up five hours behind.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Set UTC=false in /etc/sysconfig/clock, and set hwclock to local time.
2. Suspend laptop.
3. Resuem laptop.
	

Actual Results:  Sometimes system clock is set to local time minus five hours
(for EST).

Expected Results:  Clock should always resume to hwclock time if UTC=false.

Additional info:

If you don't catch this and shut down the machine with the clock set
incorrectly, then the hwclock is synced to the wrong time.  On next startup, the
system clock will be set correctly to the incorrect hwclock time.  This behavior
might have been reported as another bug some time in the past.
Comment 1 Bernhard Rosenkraenzer 2002-02-26 12:11:07 EST
That's caused by a behavior change in hwclock - older versions would always assume 
--localtime if --utc wasn't specified. 
 
Current versions use whatever was used before if neither is specified. 
 
I've adapted apmscript in apmd 3.0.2-6. 
Comment 2 Bernhard Rosenkraenzer 2002-02-26 12:29:01 EST
*** Bug 7062 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.