Bug 599947 - FTBFS python-beaker-1.5.3-2.fc14
Summary: FTBFS python-beaker-1.5.3-2.fc14
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-beaker (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Kyle VanderBeek
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: F14FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-06-03 21:05 UTC by FTBFS
Modified: 2011-10-01 01:56 UTC (History)
4 users (show)

Fixed In Version: python-beaker-1.5.4-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 19:19:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (88.17 KB, text/plain)
2010-06-03 21:05 UTC, FTBFS
no flags Details
build.log (149.19 KB, text/plain)
2010-06-03 21:05 UTC, FTBFS
no flags Details
mock.log (915 bytes, text/plain)
2010-06-03 21:05 UTC, FTBFS
no flags Details
root.log (112.63 KB, text/plain)
2010-06-03 21:05 UTC, FTBFS
no flags Details
build.log (308.18 KB, text/plain)
2010-06-03 21:05 UTC, FTBFS
no flags Details
mock.log (922 bytes, text/plain)
2010-06-03 21:05 UTC, FTBFS
no flags Details

Description FTBFS 2010-06-03 21:05:11 UTC
python-beaker-1.5.3-2.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-06-03 21:05:14 UTC
Created attachment 420549 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-06-03 21:05:15 UTC
Created attachment 420550 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-06-03 21:05:16 UTC
Created attachment 420551 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-06-03 21:05:17 UTC
Created attachment 420552 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-06-03 21:05:19 UTC
Created attachment 420553 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-06-03 21:05:20 UTC
Created attachment 420554 [details]
mock.log

mock.log for x86_64

Comment 7 Kyle VanderBeek 2010-06-03 22:23:19 UTC
This is going to be tough to work around.  It appears (at first glance) to be related to build machine load.  These tests allow 1 second worth of "fudge" to happen when testing cache item creation and such.  On the build machine, it looks like it'd need in excess of 3 seconds just to execute the few lines of python that look up the timing values and then do the comparison.  I'm not sure how much we want to crank up that fudge time as it might actually invalidate the test and hide a different issue.

Comment 8 Matt Domsch 2010-06-04 04:59:14 UTC
I've rebuilt each of the failing builds at least 6 times in the past week, on both architectures.  I'm pretty sure it would have attempted to get built on different build hosts, with various numbers of cores (often 4, some builders have more) and amount of memory (2-8GB, plus up to 16GB swap), but also with various other build activity running in parallel.  So IMHO this isn't a small transient error that can be trivially attributed to build server load.

Comment 9 Kyle VanderBeek 2010-06-05 21:49:22 UTC
It just failed on a local build, so I'll investigate.  Thanks!

Comment 10 Bug Zapper 2010-07-30 11:58:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Fedora Update System 2011-09-08 07:56:55 UTC
python-beaker-1.5.4-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-beaker-1.5.4-1.el5

Comment 12 Fedora Update System 2011-09-08 07:57:14 UTC
python-beaker-1.5.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-beaker-1.5.4-1.fc16

Comment 13 Fedora Update System 2011-09-08 07:57:27 UTC
python-beaker-1.5.4-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-beaker-1.5.4-1.fc15

Comment 14 Fedora Update System 2011-09-08 07:57:41 UTC
python-beaker-1.5.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-beaker-1.5.4-1.fc14

Comment 15 Fedora Update System 2011-09-08 20:50:23 UTC
Package python-beaker-1.5.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-beaker-1.5.4-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-beaker-1.5.4-1.fc16
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2011-09-30 19:18:51 UTC
python-beaker-1.5.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-10-01 01:29:26 UTC
python-beaker-1.5.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-10-01 01:54:37 UTC
python-beaker-1.5.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-10-01 01:56:27 UTC
python-beaker-1.5.4-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.