Bug 59995 - gtk interface messes up timidity
Summary: gtk interface messes up timidity
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: timidity++ (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 66377 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-18 18:38 UTC by rdt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-18 19:02:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
midi file that doesn't play well with gtk interface (37.84 KB, application/octet-stream)
2002-02-18 18:41 UTC, rdt
no flags Details

Description rdt 2002-02-18 18:38:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.9-21 i586)

Description of problem:
I'm finding that some (though not all) midi files don't play well using the gtk
interface, though they play well with other interfaces
such as ncurses, slang, and even motif (when this is compiled in).  The midi
playback starts normally but then stops when the window opens. The timing
information is negative (e.g. -9:-50).  I'll attach a midi file that exhibits
this behavior on timidity.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  timidity -ig file.midi
2.
3.
	

Actual Results:  The playback starts normally, but dies as soon as the window
opens,
showing negative timing information.

Expected Results:  Playback continues to the end of the piece.

Additional info:

Comment 1 rdt 2002-02-18 18:41:13 UTC
Created attachment 45901 [details]
midi file that doesn't play well with gtk interface

Comment 2 rdt 2002-02-18 19:02:41 UTC
I've found that if I leave it running until the time reaches 0, normal playback
begins at that point.  I would guess that this is an initialization bug.  

I don't think I mentioned that I'm running gtk+-1.2.10-11 and
timidity++-2.10.4-2.

Comment 3 Bernhard Rosenkraenzer 2002-02-18 20:17:05 UTC
 The frontend has been removed in the current version to avoid dependencies, anyway.

Comment 4 Michael Fulbright 2002-07-17 16:59:44 UTC
*** Bug 66377 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.