Bug 600051 - unable to run 389-console on Windows
unable to run 389-console on Windows
Status: CLOSED WORKSFORME
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
7.1
i386 Windows
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks: 389_1.3.0
  Show dependency treegraph
 
Reported: 2010-06-03 17:37 EDT by devonab
Modified: 2015-01-04 18:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 12:18:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description devonab 2010-06-03 17:37:59 EDT
Description of problem:
Iā€™m able to start 389-console on WinXP but cannot login; always fails with the error below.  


Version-Release number of selected component (if applicable): 389-Console-1.1.6-i386


How reproducible: everytime i run 389-console.bat


Steps to Reproduce:
1.run 389-console.bat
2.
3.
  
Actual results:
C:\Program Files\389 Management Console>"C:\Program Files\Java\jre6\bin\java" "-Djava.library.path=." -cp "./jss4.jar;./ldapjdk.jar;./idm-console-base.jar;./idm-console-mcc.jar;./idm-console-mcc_en.jar;./idm-console-nmclf.jar;./idm-console-nmclf_en.jar;./389-console_en.jar" -Djava.util.prefs.systemRoot=/.389-console -Djava.util.prefs.userRoot=/.389-console com.netscape.management.client.console.Console
Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Program Files\389 Management Console\jss4.dll: The specified procedure could not be found
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(Unknown Source)
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at org.mozilla.jss.CryptoManager.loadNativeLibraries(CryptoManager.java:1339)
        at org.mozilla.jss.CryptoManager.initialize(CryptoManager.java:827)
        at org.mozilla.jss.CryptoManager.initialize(CryptoManager.java:800)
        at com.netscape.management.client.util.UtilConsoleGlobals.initJSS(Unknown Source)
        at com.netscape.management.client.comm.HttpsChannel.<clinit>(Unknown Source)
        at com.netscape.management.client.comm.HttpManager.createChannel(Unknown Source)
        at com.netscape.management.client.comm.CommManager.send(Unknown Source)
        at com.netscape.management.client.comm.CommManager.send(Unknown Source)
        at com.netscape.management.client.comm.HttpManager.get(Unknown Source)
        at com.netscape.management.client.console.Console.invoke_task(Unknown Source)
        at com.netscape.management.client.console.Console.authenticate_user(Unknown Source)
        at com.netscape.management.client.console.Console.<init>(Unknown Source)
        at com.netscape.management.client.console.Console.main(Unknown Source)

Expected results:
the console starts

Additional info:
-my admin server is configured for SSL and runs on Linux
-desktop (where i am running the console) is running WinXP 32-bit
-console works fine on the server-side (Linux)
-tried installing and running the console on Win2k3; had same issue
Comment 3 DirkS 2010-09-02 08:53:43 EDT
I have the same problem using the console on windows (XP and w2k)
389-console (1.1.6) and redhat idm console
servers:
rhds 8.1 on rhel 5.x
centos 8.1 on centos 5.5
389-ds (1.2.5) on fedora 13

always wenn I enable ssl for the console (https), without ssl everything works fine.
There are no errors on linux hosts using the console.
Comment 4 Rich Megginson 2011-06-28 13:05:43 EDT
What version of Java are you using?
Comment 5 Martin Kosek 2012-01-04 08:31:41 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/86

Note You need to log in before you can comment on or make changes to this bug.