Bug 600084 - Publican 1.6.2 fails on Windows XP
Publican 1.6.2 fails on Windows XP
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.3
All Windows
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 18:24 EDT by John J. McDonough
Modified: 2013-01-23 05:27 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-23 05:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John J. McDonough 2010-06-03 18:24:03 EDT
Description of problem:
Publican crashes and burns on any command

Version-Release number of selected component (if applicable):
1.6.3

How reproducible:
reproduceable

Steps to Reproduce:
1. Install publican on Windows
2. publican --help, publican create, pretty much anything
3.
  
Actual results:
lots of messages

Expected results:
book created

Additional info:
Bare Windows XP Home install on a VM, minimal updates.

Since it seemed to be whining about ImageMagick, I tried a few ImageMagick operations and they went without a hitch (but I only tried a few).


With Admin user:
C:\Documents and Settings\root\test>publican create --name Test

Can't load 'C:\DOCUME~1\root\LOCALS~1\Temp\par-root\cache-a6aa1560065ea19bc06f2d

79cd46ac7f562b9e21\e49708b6.dll' for module Image::Magick: load_file:This applic

ation has failed to start because the application configuration is incorrect. Re

installing the application may fix this problem at C:/Perl/lib/DynaLoader.pm lin

e 201, <DATA> line 1662.

 at C:/Perl/site/lib/PAR/Heavy.pm line 128

Compilation failed in require at Publican/XmlClean.pm line 11, <DATA> line 1662.



BEGIN failed--compilation aborted at Publican/XmlClean.pm line 11, <DATA> line 1

662.

Compilation failed in require at Publican/Builder.pm line 9, <DATA> line 1662.

BEGIN failed--compilation aborted at Publican/Builder.pm line 9, <DATA> line 166

2.

Compilation failed in require at Publican/CreateBook.pm line 14, <DATA> line 166

2.

BEGIN failed--compilation aborted at Publican/CreateBook.pm line 14, <DATA> line

 1662.

Compilation failed in require at script/publican line 12, <DATA> line 1662.

BEGIN failed--compilation aborted at script/publican line 12, <DATA> line 1662.

&Image::Magick::constant not defined. The required ImageMagick libraries are not

 installed or not installed properly.

END failed--call queue aborted at -e line 959, <DATA> line 1662.




with limited user:
C:\Documents and Settings\jjmcd\Publican>publican create --name Test

Can't load 'C:\DOCUME~1\jjmcd\LOCALS~1\Temp\par-jjmcd\cache-a6aa1560065ea19bc06f

2d79cd46ac7f562b9e21\e49708b6.dll' for module Image::Magick: load_file:This appl

ication has failed to start because the application configuration is incorrect.

Reinstalling the application may fix this problem at C:/Perl/lib/DynaLoader.pm l

ine 201, <DATA> line 1662.

 at C:/Perl/site/lib/PAR/Heavy.pm line 128

Compilation failed in require at Publican/XmlClean.pm line 11, <DATA> line 1662.



BEGIN failed--compilation aborted at Publican/XmlClean.pm line 11, <DATA> line 1

662.

Compilation failed in require at Publican/Builder.pm line 9, <DATA> line 1662.

BEGIN failed--compilation aborted at Publican/Builder.pm line 9, <DATA> line 166

2.

Compilation failed in require at Publican/CreateBook.pm line 14, <DATA> line 166

2.

BEGIN failed--compilation aborted at Publican/CreateBook.pm line 14, <DATA> line

 1662.

Compilation failed in require at script/publican line 12, <DATA> line 1662.

BEGIN failed--compilation aborted at script/publican line 12, <DATA> line 1662.

&Image::Magick::constant not defined. The required ImageMagick libraries are not

 installed or not installed properly.

END failed--call queue aborted at -e line 959, <DATA> line 1662.
Comment 1 Jeff Fearn 2010-06-10 00:06:42 EDT
Hi John, can you confirm whether or not you chose to install Image Magick when installing Publican?

The only Windows XP machine I have access to is my devel box. Which isn't exactly a clean environment to test on. I do have a Vista box and I can't get this bug to happen on that.

Cheers, Jeff.
Comment 2 John J. McDonough 2010-06-10 07:01:46 EDT
Jeff, I did install ImageMagick, and I did a few ImageMagick operations to see that it installed correctly (since the messages seemed ImageMagick related) and they seemed to work.  I did not do any extensive testing though.

I installed it on a VM with a clean XP Home install.  The only other app installed is Microchip's MPLAB (which shouldn't have much to do with anything).  Later I tried updating the XP install to SP2 and also tried Publican 1.5, but all gave the same result.
Comment 3 John J. McDonough 2010-07-07 07:58:30 EDT
It occurred to me in looking at the message that perhaps there was some Perl dependency.  I tried installing phpdev, but the latest version no longer seems to include Perl so that didn't help.  Nor did Strawberry Perl.

I then installed it on a machine that had an older version of phpdev which included Perl, and on the first command, "publican --help", I got a message about being unable to write to a file, followed by the correct help text.  Thereafter the message never appeared and the application seemed to work properly.

However, besides phpdev, this machine was an XP/Pro machine (all other tests were on XP/Home), and I had ticked an option in the ImageMagick part of the install that may have been relevant and I'm not sure I had ticked that on the XP/Home installs.

I seem to recall the earlier installs having given me the option of installing ImageMagick, however, this time it did not.  I believe I used the same installer executable.

So it appears the issue is related to one of three things:
1) XP/Home vs. Pro
2) Previously installed Perl support
3) Getting the options right on ImageMagick

I'll do further testing.
Comment 4 Jeff Fearn 2010-09-14 18:08:28 EDT
Hi John, I've uploaded a publican 2.1 installer, could you give it a run and see if it fixes this problem?

https://fedorahosted.org/releases/p/u/publican/Publican-Installer-2.1.exe

Cheers, Jeff.
Comment 5 John J. McDonough 2010-09-29 08:40:50 EDT
Jeff

Very similar response:

C:\Documents and Settings\root\My Documents\Publican>publican create --type=arti

cle --lang=en-US --name=Test_Doc

IO error: Can't open file C:\DOCUME~1\root\LOCALS~1\Temp\par-root\cache-cb951892

2e4e7a3ec603791136521066f6f2418c/inc/lib/publican for write : Permission denied



 at -e line 944

Can't load 'C:\DOCUME~1\root\LOCALS~1\Temp\par-root\cache-cb9518922e4e7a3ec60379

1136521066f6f2418c\e49708b6.dll' for module Image::Magick: load_file:This applic

ation has failed to start because the application configuration is incorrect. Re

installing the application may fix this problem at C:/Perl/lib/DynaLoader.pm lin

e 201.

 at C:/Perl/site/lib/PAR/Heavy.pm line 128

Compilation failed in require at Publican/XmlClean.pm line 10.

BEGIN failed--compilation aborted at Publican/XmlClean.pm line 10.

Compilation failed in require at Publican/Builder.pm line 9.

BEGIN failed--compilation aborted at Publican/Builder.pm line 9.

Compilation failed in require at Publican/CreateBook.pm line 12.

BEGIN failed--compilation aborted at Publican/CreateBook.pm line 12.

Compilation failed in require at script/publican line 9.

BEGIN failed--compilation aborted at script/publican line 9.

&Image::Magick::constant not defined. The required ImageMagick libraries are not

 installed or not installed properly.

END failed--call queue aborted at -e line 959.



C:\Documents and Settings\root\My Documents\Publican>

Virtually the same response when run from a non-admin user
Comment 6 John J. McDonough 2010-09-29 14:05:58 EDT
I went ahead and installed 2.1 on XP/Pro (which had worked previously).  The first time i tried to create a document, I got an error:

C:\Documents and Settings\jjmcd\My Documents\Publican>publican create --lang=en-

US --type=article --name=Test

IO error: Can't open file C:\DOCUME~1\jjmcd\LOCALS~1\Temp\par-jjmcd\cache-cb9518

922e4e7a3ec603791136521066f6f2418c/inc/lib/publican for write : Permission denie

d

 at -e line 944

        Processing file en-US/Article_Info.xml -> en-US/Article_Info.xml

        Processing file en-US/Author_Group.xml -> en-US/Author_Group.xml

        Processing file en-US/Revision_History.xml -> en-US/Revision_History.xml



        Processing file en-US/Test.xml -> en-US/Test.xml



C:\Documents and Settings\jjmcd\My Documents\Publican>



However, the document appeared to be created correctly, and built for all formats except pdf.  pdf gave a message:

C:\Documents and Settings\jjmcd\My Documents\Publican\Test>publican build -l en-

US -f pdf

Setting up en-US

        Processing file tmp/en-US/xml/Common_Content/Conventions.xml -> tmp/en-U

S/xml/Common_Content/Conventions.xml

        Processing file tmp/en-US/xml/Common_Content/Feedback.xml -> tmp/en-US/x

ml/Common_Content/Feedback.xml

        Processing file tmp/en-US/xml/Common_Content/Legal_Notice.xml -> tmp/en-

US/xml/Common_Content/Legal_Notice.xml

        Processing file tmp/en-US/xml_tmp/Article_Info.xml -> tmp/en-US/xml/Arti

cle_Info.xml

        Processing file tmp/en-US/xml_tmp/Author_Group.xml -> tmp/en-US/xml/Auth

or_Group.xml

        Processing file tmp/en-US/xml_tmp/Revision_History.xml -> tmp/en-US/xml/

Revision_History.xml

        Processing file tmp/en-US/xml_tmp/Test.xml -> tmp/en-US/xml/Test.xml

Beginning work on en-US

        Starting pdf

        Using XML::LibXSLT on C:/Program Files/Publican/xsl/pdf.xsl

Making portrait pages on A4 paper (210mmx297mm)

'fop' is not recognized as an internal or external command,

operable program or batch file.

        Finished pdf



C:\Documents and Settings\jjmcd\My Documents\Publican\Test>


and produced no output.

A couple of other interesting things ...

I could not load the generated ePub into Calibre, although I had earlier loaded a publican-produced ePub.  I do recall, however, that getting it in was a little strange and I'm not certain I tried all the right things.

Also, when I created a document using my homebrew brand (installed on Windows by simply copying files from Linux), I did not get the error on create.

My brand made the table of contents appear for an article (no I don't remember how I did that), and it did not appear when a previously produced document was built on Windows.  That is the only difference I could find in copies of that document produced using Fedora or Windows versions of Publican (in both cases 2.1)

Note You need to log in before you can comment on or make changes to this bug.