Bug 60015 - Stop scripts are not linked by running chkconfig.
Summary: Stop scripts are not linked by running chkconfig.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-19 02:12 UTC by Steven W. Orr
Modified: 2014-03-17 02:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 02:39:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven W. Orr 2002-02-19 02:12:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-ac10 i686)

Description of problem:
When running chkconfig to add a service to all relevant runlevels or just to one
runlevel, the stop script is not created.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. chkconfig --add sendmail
2. cd /etc/rc.d/rc3.d
3. ls *sendmail*
	

Actual Results:  The S80sendmail script is created but the K20sendmail link is
not.

Expected Results:  Both the S80sendmail and K20sendmail links should have been
created.

Additional info:

As far as I can see, the start script is always created and the stop script is
never created.

Severity really depends on the application and whether there is data loss if an
improper shutdown occurs.

Comment 1 Bill Nottingham 2002-02-19 02:39:52 UTC
I can't reproduce this here.

[root@nostromo notting]# chkconfig --del sendmail
[root@nostromo notting]# ls /etc/rc*.d/*sendmail
ls: /etc/rc*.d/*sendmail: No such file or directory
[root@nostromo notting]# chkconfig --add sendmail
[root@nostromo notting]# ls /etc/rc*.d/*sendmail
/etc/rc0.d/K30sendmail  /etc/rc3.d/S80sendmail  /etc/rc6.d/K30sendmail
/etc/rc1.d/K30sendmail  /etc/rc4.d/S80sendmail
/etc/rc2.d/S80sendmail  /etc/rc5.d/S80sendmail

All the proper links are created.


Note You need to log in before you can comment on or make changes to this bug.