Bug 600153 - iso mounts have some zero-length files
iso mounts have some zero-length files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 23:12 EDT by Josh Stone
Modified: 2016-07-15 05:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 05:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 675775 None None None 2016-07-15 05:44 EDT

  None (edit)
Description Josh Stone 2010-06-03 23:12:27 EDT
Description of problem:
When I mount an iso with gvfs, I see some files have no content when they should.  A simple public example is "Fedora-13-i386-netinst.iso", with "isolinux/initrd.img" and "images/pxeboot/vmlinuz" showing zero length.  Any file operation like opening them or copying to another location results in an empty file.

There are also files "images/pxeboot/initrd.img" and "isolinux/vmlinuz" which look fine.  I suspect that these are identical to the missing files, and some data sharing is happening in the ISO format.


Version-Release number of selected component (if applicable):
gvfs-archive-1.4.3-8.el6.i686


How reproducible:
100%


Steps to Reproduce:
1. Double-click an iso in nautilus to mount it with gvfs.
2. Browse the mounted filesystem.
3. Witness the zero-length files.
  
Actual results:
Some files have no content.


Expected results:
All files are properly available.


Additional info:
If I instead right-click on the iso and choose "Open with Archive Manager", then I can see every file with the proper size.

Also FWIW, this same issue appears on Fedora 13 with gvfs-1.6.1-3.fc13.x86_64.
Comment 2 RHEL Product and Program Management 2010-06-04 12:13:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Tomáš Bžatek 2010-06-23 12:36:36 EDT
Oh, this looks like a problem in libarchive. Old libarchive-2.7.1 can read the ISO file correctly. Generally, libarchive is not good in ISO9660 images handling. Reproducible with libarchive-2.8.3-1.el6.x86_64
Comment 5 Tomáš Bžatek 2010-06-30 11:35:42 EDT
FYI, I've bisected the change to a bad commit r1419

http://code.google.com/p/libarchive/source/detail?r=1419&path=/trunk/libarchive/archive_read_support_format_iso9660.c
Comment 6 Tomáš Bžatek 2010-06-30 12:06:15 EDT
OK, I was wrong, bsdtar showed hardlinks yet gvfsd-archive doesn't support them at the moment.
Comment 10 Aleksandra Fedorova 2011-02-27 20:15:46 EST
same problem here on f14 

# rpm -qa | grep archive
gvfs-archive-1.6.6-1.fc14.x86_64
libarchive-2.8.4-1.fc14.x86_64
Comment 13 Suzanne Yeghiayan 2012-02-14 17:59:42 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Note You need to log in before you can comment on or make changes to this bug.