Bug 600203 - vhost net new userspace on old kernel: 95: falling back on userspace virtio
vhost net new userspace on old kernel: 95: falling back on userspace virtio
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 02:52 EDT by Keqin Hong
Modified: 2013-01-09 17:40 EST (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.72.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:25:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keqin Hong 2010-06-04 02:52:00 EDT
Description of problem:
When starting a RHEL6 guest on RHEL6 host with vhost on, qemu monitor prompts "unable to start vhost net: 95: falling back on userspace virtio". Starting a RHEL5.5 guest doesn't have the issue.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.69.el6.x86_64

How reproducible:
100%

# lsmod | grep vhost
vhost_net              22833  0 
macvtap                 7573  1 vhost_net
tun                    16295  1 vhost_net


CLI:
# /usr/libexec/qemu-kvm -m 2G -smp 2 -drive file=RHEL6.0-64-virtio.qcow2,if=none,id=drive-virtio0,boot=on -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0,addr=0x3 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,mac=76:00:40:3F:20:20,bus=pci.0,addr=0x4 -boot order=c,menu=on -uuid 17644ecc-d3a1-4d3c-a386-12daf50015f2 -rtc base=utc -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -cpu qemu64,+sse2 -balloon none -vnc :1


Steps to Reproduce:
1. Start VM with vhost on using CLI give above

Actual results:
qemu monitor prompts "unable to start vhost net: 95: falling back on userspace virtio"

Expected results:
no such prompt and vhost net should work fine for rhel6 guest.

Additional info:    
host info:
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 67
model name	: Dual-Core AMD Opteron(tm) Processor 1216
stepping	: 3
cpu MHz		: 1000.000
cache size	: 1024 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
bogomips	: 2009.36
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
Comment 2 Keqin Hong 2010-06-04 02:57:25 EDT
guest info:
kernel-2.6.32-33.el6
Comment 3 RHEL Product and Program Management 2010-06-04 05:23:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Amit Shah 2010-06-04 05:23:41 EDT
What are the permissions you see on /dev/vhost-net? What are the SELinux permissions? Is your system configured for selinux to be in enforcing mode? Does disabling selinux make this work?
Comment 5 Keqin Hong 2010-06-04 05:48:31 EDT
# ll /dev/vhost-net 
crw-rw----. 1 root root 10, 233 Jun  4 10:58 /dev/vhost-net

# getenforce
Permissive

I guess it is not related with permission or selinux, since the issue only happens on rhel6 guest not on rhel5
Comment 6 Amit Shah 2010-06-04 06:01:23 EDT
The output of ls -lZ /dev/vhost-net will give you the selinux labels as well.

vhost support is transparent to the guest, so the type of guest shouldn't be a concern.

If you're getting this only with rhel6 then it could be an MSI-related issue.
Comment 7 Keqin Hong 2010-06-04 06:08:26 EDT
# ls -lZ /dev/vhost-net 
crw-rw----. root root system_u:object_r:device_t:s0    /dev/vhost-net

Tested again on qemu-kvm-0.12.1.2-2.68.el6.x86_64, the problem doesn't exist.
So a Regression.
Comment 8 Amit Shah 2010-06-04 06:12:03 EDT
Error code 95 is EOPNOTSUPP. mst should have a better idea on what's the failing route. It's surprising the same cmd line works fine for rhel5 guest.
Comment 9 Amit Shah 2010-06-04 06:18:56 EDT
The changelog for the .69 build had this bit related to virtio/vhost-net:

- kvm-virtio-utilize-PUBLISH_USED_IDX-feature.patch [bz#595287]
- Resolves: bz#595287
  (virtio net/vhost net speed enhancements from upstream kernel)
Comment 12 Keqin Hong 2010-06-06 23:32:32 EDT
mst,
The problem came in Comment 0 because the host testing kernel was 2.6.32-25.el6.x86_64. The problem doesn't exist on host kernel 2.6.32-30.el6.x86_64 or 2.6.32-33.el6.x86_64. Obviously, this is fixed by solving Bug 593158.

However, it is still strange if you look at Comment 7 where host kernel 2.6.32-25.el6.x86_64 with qemu-kvm-0.12.1.2-2.68.el6.x86_64 didn't have the problem.

If it is not a problem (that we don't care), I think I shall close this one as NOTABUG. Sorry for making this trouble to all of you.
Comment 13 Michael S. Tsirkin 2010-06-07 05:45:21 EDT
This is interesting in that rhel qemu should work on
upstream kernels. So this could be a bug, but not
a blocker and low priority.

I will change the title appropriately.
Comment 14 Keqin Hong 2010-06-07 05:52:53 EDT
Thanks, Michael.
Comment 17 Keqin Hong 2010-06-12 04:25:36 EDT
Verified on qemu-kvm-0.12.1.2-2.73.el6 with either kernel-2.6.32-25.el6.x86_64 or  kernel-2.6.32-33.el6.x86_64. PASS
Comment 18 juzhang 2010-06-22 01:50:28 EDT
Tested on qemu-kvm-0.12.1.2-2.77.el6

When starting a RHEL6 guest on RHEL6 host with vhost on, qemu monitor prompts
"(qemu) Error binding host notifier: 28
unable to start vhost net: 28: falling back on userspace virtio".


CLI:
/usr/libexec/qemu-kvm -usbdevice tablet -rtc-td-hack -m 2G -smp 2 -drive file=/root/zhangjunyi/rhel6_2.33_641.qcow2,if=virtio,boot=on,cache=none,format=qcow2,werror=stop,rerror=stop -drive file=/root/zhangjunyi/password.qcow2,if=virtio,format=qcow2,cache=none,werror=stop,rerror=stop -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=22:11:22:45:61:98 -netdev tap,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=22:11:22:45:62:98 -uuid `uuidgen` -cpu qemu64,+x2apic -device virtio-balloon-pci -boot order=cn,menu=on -monitor stdio -vnc :10 -qmp tcp:0:4444,server,nowait -qmp tcp:0:4445,server,nowait -name zhangjunyi

Please NOTE:
This issue only happened when boot two virtio nics,boot one virtio nic doesn't have the issue.

host info
2.6.32-36.el6.x86_64

guest info:
kernel-2.6.32-33.el6
Comment 20 Michael S. Tsirkin 2010-06-22 07:01:00 EDT

*** This bug has been marked as a duplicate of bug 602262 ***
Comment 22 releng-rhel@redhat.com 2010-11-10 16:25:28 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.