Bug 600218 - [abrt] crash in lftp-4.0.7-1.fc13: Process /usr/bin/lftp was killed by signal 11 (SIGSEGV)
[abrt] crash in lftp-4.0.7-1.fc13: Process /usr/bin/lftp was killed by signal...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lftp (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
abrt_hash:a4bd7d977971e005252e9f042e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 03:28 EDT by Ilkka Tengvall
Modified: 2014-11-09 17:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 10:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.44 KB, text/plain)
2010-06-04 03:28 EDT, Ilkka Tengvall
no flags Details
fixes crash when corrupted date (966 bytes, patch)
2010-06-28 08:56 EDT, Jiri Skala
no flags Details | Diff

  None (edit)
Description Ilkka Tengvall 2010-06-04 03:28:15 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: lftp hftp://ftp.windriver.com
comment: I tried to upload a file to ftp drop box via http proxy. Lftp crashed after sending some data. I tried few times, always the same crash.
component: lftp
executable: /usr/bin/lftp
global_uuid: a4bd7d977971e005252e9f042e2cbfa67a3bc953
kernel: 2.6.33.5-112.fc13.x86_64
package: lftp-4.0.7-1.fc13
rating: 4
reason: Process /usr/bin/lftp was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. export http_proxy="http://foo.bar.com:8080/; export ftp_proxy="http://foo.bar.com:8080/; export proxy="http://foo.bar.com:8080/;
2. dd if=/dev/zero of=/tmp/please-remove-lftp-test.bin bs=1024 count=1024
2. lftp ftp.windriver.com
3. cd incoming
4. put /tmp/please-remove-lftp-test.bin
 -> lftp ftp.windriver.com:~/incoming> put /tmp/please-remove-lftp-test.bin 
Segmentation fault (core dumped)n' at 196608 (18%) 2.7K/s eta:5m [Waiting for response...]
Comment 1 Ilkka Tengvall 2010-06-04 03:28:18 EDT
Created attachment 421146 [details]
File: backtrace
Comment 2 Jiri Skala 2010-06-22 13:47:09 EDT
Hi,
thank you for reporting. I was not able to reproduce the bug but the backtrace has provided enough information. I suppose the issue was produced by corrupted mtime.

I've patched affected code and built rawhide's rpm. Please, if you are able to reproduce it could you test ptached rpm using:

yum update lftp --enablerepo=rawhide

Thanks

Jiri
Comment 3 Ilkka Tengvall 2010-06-28 08:32:16 EDT
thanks, I did try it with version:

lftp-4.0.9-2.fc14.x86_64

It didn't crash anymore. Didn't upload the file either :) It uploaded the file to some phase, but then it goes to such state:

$ lftp hftp://ftp.windriver.com
lftp ftp.windriver.com:~> cd incoming
cd ok, cwd=~/incoming                    
lftp ftp.windriver.com:~/incoming> put /tmp/please-remove-lftp-test.bin 
`...please-remove-lftp-test.bin' at 0 (0%)

and just keeps updating the ETA time. I'm not sure if the download finished or not.

Here's the failed wireshark capture of the TCP stream:

-------------------------------------------------
# cat Desktop/lftp-hftp-wr.com.pcap 
PUT ftp://ftp.windriver.com/incoming/please-remove-lftp-test.bin;type=i HTTP/1.1
Host: ftp.windriver.com
User-Agent: lftp/4.0.9
Content-length: 1048576
Last-Modified: Mon, 28 Jun 12:02:37 2010 GMT
Connection: close

HTTP/1.1 200 OK
Via: 1.1 FIESPRX001
Pragma: no-cache
Cache-Control: no-cache
Content-Type: text/html

<HTML>
<meta http-equiv="Content-Type" content="text-html; charset=UTF-8">
<HEAD>
<TITLE>Server error message </TITLE>
</HEAD>
<BODY><H1>ISA Server: extended error message : </H1>
<PRE>200 Switching to Binary mode.
227 Entering Passive Mode (192,124,127,9,195,154)
550 Failed to open file.
</PRE>
</BODY>
</HTML>
-------------------------------------------------
Comment 4 Jiri Skala 2010-06-28 08:56:10 EDT
Created attachment 427408 [details]
fixes crash when corrupted date

Thanks for test and report. I've got the same issue with ftp.windriver.com.

I made test environment with vsftpd and squid. Patched code worked fine. Well, I'm going to put the patch to F-12, F-13 and upstream.
Comment 5 Ilkka Tengvall 2010-06-29 03:14:06 EDT
thanks

Note You need to log in before you can comment on or make changes to this bug.