Bug 600223 - RFE: SMBIOS: Detect and pass host serial # to guest OS
RFE: SMBIOS: Detect and pass host serial # to guest OS
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks: libvirtTodoHV
  Show dependency treegraph
 
Reported: 2010-06-04 03:48 EDT by Grant Williamson
Modified: 2011-07-07 10:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-07 10:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grant Williamson 2010-06-04 03:48:49 EDT
Description of problem:
For the registration and license management of guest OS, it is important that we can track the serial information of the host machine being used from within the guest os.
We would like libvirt to be able to detect the following. Which can be found on most machines using dmidecode.

Serial Number: xxxxxxx
UUID: xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

This could then be offered/detected by the guest OS.

I spoke to Jonathan Blandford, who asked me to open a ticket for this request.
Comment 1 Jon Stanley 2011-04-20 13:09:18 EDT
Note that it's also important to be able to pass arbitrary values in these SMBIOS fields (and others) - we're particularly interested in asset tag (which is in SMBIOS type 3, which is unsupported by QEMU at the moment), but being able to set arbitrary values in serial number is useful as well. 

This part is already there:

http://libvirt.org/formatdomain.html#elementsSysinfo

The part that was originally requested, the ability to pass through the values from the host, isn't there. I assume this is only applicable for the qemu driver, since it's the "most important" driver in libvirt for enterprise customers.
Comment 2 Daniel Berrange 2011-04-21 04:58:29 EDT
> The part that was originally requested, the ability to pass through the values
> from the host, isn't there.

Yes it is:

  http://libvirt.org/formatdomain.html#elementsOSBIOS

  "<smbios>: The mode attribute must be specified, and is either "emulate" (let the hypervisor generate all values), "host" (copy all of Block 0 and Block 1, except for the UUID, from the host's SMBIOS values; the virConnectGetSysinfo call can be used to see what values are copied), or "sysinfo" (use the values in the sysinfo element).

eg, to pass values from the host:

  <os>
    ....
    <smbios mode='host'/>
  </os>

Note You need to log in before you can comment on or make changes to this bug.