Bug 600231 - libssh(?) creates garbage into .ssh
Summary: libssh(?) creates garbage into .ssh
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libssh   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jan F. Chadima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-04 08:12 UTC by niklas.laxstrom+bro@gmail.com
Modified: 2011-01-18 19:59 UTC (History)
3 users (show)

Fixed In Version: libssh-0.4.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-18 19:59:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description niklas.laxstrom+bro@gmail.com 2010-06-04 08:12:18 UTC
Description of problem:
I just noticed my .ssh folder is full of directories with garbage in the name. First of them was created in 23.5. libssh was updates 20.5. (so the problem started before I updated to F13 and continued after it). Each folder contains just one file known_hosts with one item. Those items seems to correspond to the annoying "Could not verify identity of server X" warnings, when I use Kate and sftp-kioslave to open files on remote host (which is definitely in my real known_hosts files)

Version-Release number of selected component (if applicable):
May 20 17:09:56 Updated: libssh-0.4.3-1.fc12.x86_64

Nimi            : libssh
Arkkitehtuuri   : i686
Versio          : 0.4.3
Julkaisu        : 1.fc13

Arkkitehtuuri   : x86_64
Versio          : 0.4.3
Julkaisu        : 1.fc13
Koko            : 255 k

How reproducible:
I get 3 to 6 folders a day when working with remote files over sftp kioslave.


Steps to Reproduce:
1. Open kate
2. Browse to a remote server using sftp-kioslave
3. Open many (the more the better?) files
4. Observer warnings and new folders in .ssh

It does not happen every time. Related problem is that if I have alias for host in .ssh/config, they also fail to work occassionally.
  
Actual results:
Warnings, garbage folders in .ssh

Expected results:
No warnings, no garbage

Additional info:
Interesting bits from 0.4.4 release notes:
-Fixed a bug in the expand function for escape sequences.
-Fixed a bug in the tilde expand function.

This scared the heck out of me until I figured the reason. I though I was hacked.

Comment 1 Andreas Schneider 2010-06-04 08:50:32 UTC
This should be fixed with bug #598592. The problem was that a string was not correctly terminated. So the last char was garbage on some systems. Our torture tests passed on the systems we've tested the stuff, sorry.

Comment 2 Jan F. Chadima 2010-06-04 09:32:54 UTC
(In reply to comment #1)
> This should be fixed with bug #598592. 

The libssh-0.4.4 is in the testing branch for f-13

Comment 3 Andreas Schneider 2011-01-18 11:05:54 UTC
I think this can be closed.


Note You need to log in before you can comment on or make changes to this bug.