Bug 600232 - Name for logs is too long to show suitably in the Logs field on web UI
Name for logs is too long to show suitably in the Logs field on web UI
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.5
All Linux
low Severity low (vote)
: 0.15.1
: ---
Assigned To: xjia
tools-bugs
UX
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 04:22 EDT by Igor Zhang
Modified: 2015-07-19 20:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 02:58:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
harness side patch (1.66 KB, patch)
2010-08-11 01:35 EDT, Marian Csontos
mcsontos: review?
Details | Diff

  None (edit)
Description Igor Zhang 2010-06-04 04:22:45 EDT
Description of problem:
Name for logs is too long to show suitably in the Logs field on web UI
Like here https://beaker.engineering.redhat.com/recipes/3007
If we roll out the resules, look into the Logs field. We will see:
st_log--distribution-kernelinstall-rhts-reboot.log
tion-kernelinstall-kernel-smp-2.6.9-89.0.25.EL.log

And they should be
test_log--distribution-kernelinstall-rhts-reboot.log
test_log--distribution-kernelinstall-kernel-smp-2.6.9-89.0.25.EL.log

Version-Release number of selected component (if applicable):
Beaker Version - 0.5.41 

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marian Csontos 2010-08-11 01:24:08 EDT
It's how rhts-db-submit-result names the file and I could remove it easily, but have a dilemma:

- when downloading files from WebUI it is not bad having a descriptive filename.
- On the other hand I do not think WebUI should tinker with filenames.

Thus harness should send both short and long names.

Unfortunately there is no file database and files are hold in filesystem only.
Is it sure beaker will always run on a FS able to store extended metadata?
May be we could use a .../short-name/long-name schema instead and this seems the most reasonable thing to do:

- No big changes.
  - simple changes on harness side
  - not that bad for WebUI too
- Bonus: This would solve Bug 584518 too.

Proposed changes to WebUI:
- display only directory-names, not files.
  - exception: top-level-files - backward compatibility and convenience

- file links would link to themselves
- directory links would:
  - if there are multiple files, display a list (AJAX?),
  - if there is single file in directory, link would be direct to the file.

Folks?
Comment 2 Marian Csontos 2010-08-11 01:35:56 EDT
Created attachment 438080 [details]
harness side patch

On lab-machine it would be as easy as this.
Sorry Ray... ;-)
Comment 3 Ed Santiago 2010-10-14 12:49:43 EDT
Suggestion: for Web UI, since the test names are in the same row already, would it make sense to use short descriptive labels instead of semicomplete paths?

  [log]  (or [output] or [stdout/stderr])
  [dmesg]
  [avc]
Comment 4 Ed Santiago 2011-12-02 16:24:34 EST
Documented my GreaseMonkey script, with screen captures:

  http://file.bos.redhat.com/~esantiag/beaker-colorize/
Comment 6 Dan Callaghan 2013-10-11 08:00:22 EDT
For the reasons given in comment 1 I don't think the filenames used by rhts-* should be changed, nor that Beaker should fiddle with them.

And anyway even if that were changed, Beaker accepts arbitrarily named file uploads so it still needs to deal with this problem of displaying long log file names.

I think the real issue is that the log filenames are truncated (in Python, not in CSS) to the final 50 characters, even though in most cases the useful distinguishing information is at the start (test_log-..., avc_log-...). Also it seems that the results UI has evolved since the original bug report because the logs are separated according to their result, so there will normally only be one test_log-... file in each row.

We can skip truncating the filenames in Python and instead use the text-overflow CSS property along with a max-width to prevent long log filenames from blowing out the width of the results table.

http://gerrit.beaker-project.org/2351

We could also put the complete filename in the title attribute to make it easier to distinguish filenames that have been truncated, although the browser will already show the complete URL when hovering so maybe that isn't necessary.
Comment 9 Raymond Mancy 2013-10-23 02:58:22 EDT
beaker 0.15.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.