Bug 60025 - Toshiba XM-3301 CD-ROM not recognized at RH 7.2
Toshiba XM-3301 CD-ROM not recognized at RH 7.2
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-02-19 00:07 EST by jac
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output from dmesg command (5.38 KB, text/plain)
2002-02-26 23:50 EST, jac
no flags Details

  None (edit)
Description jac 2002-02-19 00:07:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i486)

Description of problem:
If an XM-3301 CD-rom is connected to the AHA-1522 controller,
  mount /dev/scd0 /c0
fails with "unknown device".  If an XM-5701 is connected instead, the mount
command succeeds.  The same XM-3301 drive mounts properly under any RH from 4.0
through 6.2, and installs 7.2 successfully.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install RH 7.2 using the AHA-1522 and XM-3301.
2.  Log in as root.  Attempt to mount /dev/scd0.  Error message appears.
3.  Shut down, change CD-ROM, reboot and repeat test.  mount succeeds.
4.  Put back XM-3301.  Install RH 6.2 on the same host, reboot and repeat test. 
mount succeeds.

Additional info:

Searched config files under /usr/src/linux.  Didn't see anything that appeared
to be related to specific scsi CD-ROM drives.
Comment 1 Arjan van de Ven 2002-02-19 03:42:25 EST
Can you attach "dmesg" output?
Comment 2 jac 2002-02-26 23:50:02 EST
Created attachment 46740 [details]
Output from dmesg command
Comment 3 jac 2002-02-26 23:53:10 EST
Sent requested file as an attachment.  Hope it arrived.
Comment 4 Arjan van de Ven 2002-02-27 06:19:12 EST
The 3301TA  is found just fine. Hm.
Could you try the following simple thing: type "depmod -ae" as root and try
again. Might be something very stupid in the autoloading of drivers and depmod
-ae resets some information there.
Comment 5 jac 2002-03-06 20:44:22 EST
	Found a clue.  Just happened to change the SCSI ID of the XM-3301 from 3 (its default) to 2, which is what the XM-5701 was set 

to in order not to conflict with the 3301 when they're on the same system.  Booted, and the system recognized the 3301.  mount 

worked.  So it looks like maybe the new bug is in some compile-time config option in the AHA-152x driver, or possibly in its source 

code.  I can't imagine that any run-time config setting would affect this.  Prior to 7.2,  I was always able to set any CD-ROM to any SCSI 

ID, and the system would recognize it at boot.

	For some reason, your request about depmod didn't get into my e-mail, so I didn't see it until now.  Still want me to run that test?

Comment 6 jac 2002-04-10 01:04:40 EDT
	The successful mounting of a SCSI CD-ROM at ID=2 appears to have been a fluke. 
After shutting down and re-booting, I couldn't get it to mount again.  It never
worked again after a re-install of RH 7.2, at any SCSI ID.  However, a SCSI hard
disk on the same cable at ID=0 always mounted successfully, so the aha1542
module is working to some degree.
	The same set of hardware always works without problems under RH 6.0, RH 6.2,
and Libranet 2.0 (Linux 2.4.16).
	These observations suggest that the bug occurs only with Linux 2.4, but not
with all Linux 2.4 distributions.  Its randomness hints at an initialization
problem or a driver race condition.
	I don't think I'm going to do any more work on this unless you want me to help
with specific tests.  This bug cripples my system too badly to get any useful
work done, especially when added to the XFree86 problems I haven't even written
bug reports on, so I've given up on Red Hat now that all the hardware I need is
fully functional under Libranet.  But since I have the extra hard disk on the
machine now, I can load a test OS without affecting the Libranet installation.
Comment 7 Bugzilla owner 2004-09-30 11:39:23 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.