Bug 600257 - Cannot boot live CD, hangs in boot process
Cannot boot live CD, hangs in boot process
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 05:53 EDT by Michael Monreal
Modified: 2010-07-28 11:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 11:25:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample vm config xml (1.94 KB, text/plain)
2010-06-09 15:28 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2010-06-04 05:53:14 EDT
On a Fedora 13 system with the packages listed below I am unable to boot a newly created VM with the Fedroa 13 final live CD.

The grub menu is diisplayed correctly, however after that, the boot seems to get stuck on a black screen with just a "_" or "-" character in what looks like line 4.

kernel-2.6.33.5-112.fc13.i686
qemu-img-0.12.3-8.fc13.i686
gpxe-roms-qemu-1.0.0-1.fc13.noarch
qemu-common-0.12.3-8.fc13.i686
qemu-system-x86-0.12.3-8.fc13.i686
qemu-kvm-0.12.3-8.fc13.i686
libvirt-python-0.7.7-4.fc13.i686
virt-manager-0.8.4-1.fc13.noarch
libvirt-client-0.7.7-4.fc13.i686
libvirt-0.7.7-4.fc13.i686
python-virtkey-0.50-6.fc12.i686
python-virtinst-0.500.3-1.fc13.noarch

I installed the latest packages from the testing repository after running into problems first but they didn't help.
Comment 1 Michael Monreal 2010-06-04 05:54:28 EDT
The live CD is i686 just like the host system.
Comment 2 Michael Monreal 2010-06-04 06:00:55 EDT
I now tried to boot the latest bfo.iso and it hangs after "Probing EDD (edd=off to disable)... OK"
Comment 3 Cole Robinson 2010-06-09 11:28:22 EDT
Does the CD boot on a physical machine? How about:

qemu-system-x86 -cdrom ISO    and
qemu-kvm -cdrom ISO

Can you provide sudo virsh dumpxml $VMNAME ?
Comment 4 Michael Monreal 2010-06-09 15:24:53 EDT
qemu-system-x86_64 -cdrom f13.iso   =>   works but very slow
qemu-kvm -cdrom f13.iso   =>   works and is fast

So I guess we can rule out Qemu or KVM as the problem.

I'll attach the XML in a minute
Comment 5 Michael Monreal 2010-06-09 15:28:27 EDT
Created attachment 422663 [details]
sample vm config xml
Comment 6 Michael Monreal 2010-07-28 05:27:26 EDT
I tried about every stable and testing update of the virt* stack and it's still all the same. Things work fine from the console using qemu-kvm directly, but the virt* tools seem to be horribly broken in F13 :(

Currently installed packages:

virt-manager-0.8.4-1.fc13.noarch
python-virtinst-0.500.3-2.fc13.noarch
libvirt-python-0.8.2-1.fc13.i686
libvirt-client-0.8.2-1.fc13.i686
python-virtkey-0.50-6.fc12.i686
libvirt-0.8.2-1.fc13.i686
Comment 7 Cole Robinson 2010-07-28 09:05:34 EDT
Hmm, can you pull python-virtinst from updates testing, and recreate the livecd VM? I'll try to reproduce this.

If you can still reproduce after the update, please attach the new XML. Thanks.
Comment 8 Michael Monreal 2010-07-28 11:25:24 EDT
(In reply to comment #7)
> Hmm, can you pull python-virtinst from updates testing, and recreate the livecd
> VM? I'll try to reproduce this.

Wow... looks like I missed a testing update for once and this one fixed the problem :)

At least I can boot F13 and Ubuntu 10.04 live isos just fine again now, so I guess we can close this.

Note You need to log in before you can comment on or make changes to this bug.