Bug 600257 - Cannot boot live CD, hangs in boot process
Summary: Cannot boot live CD, hangs in boot process
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-04 09:53 UTC by Michael Monreal
Modified: 2010-07-28 15:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 15:25:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample vm config xml (1.94 KB, text/plain)
2010-06-09 19:28 UTC, Michael Monreal
no flags Details

Description Michael Monreal 2010-06-04 09:53:14 UTC
On a Fedora 13 system with the packages listed below I am unable to boot a newly created VM with the Fedroa 13 final live CD.

The grub menu is diisplayed correctly, however after that, the boot seems to get stuck on a black screen with just a "_" or "-" character in what looks like line 4.

kernel-2.6.33.5-112.fc13.i686
qemu-img-0.12.3-8.fc13.i686
gpxe-roms-qemu-1.0.0-1.fc13.noarch
qemu-common-0.12.3-8.fc13.i686
qemu-system-x86-0.12.3-8.fc13.i686
qemu-kvm-0.12.3-8.fc13.i686
libvirt-python-0.7.7-4.fc13.i686
virt-manager-0.8.4-1.fc13.noarch
libvirt-client-0.7.7-4.fc13.i686
libvirt-0.7.7-4.fc13.i686
python-virtkey-0.50-6.fc12.i686
python-virtinst-0.500.3-1.fc13.noarch

I installed the latest packages from the testing repository after running into problems first but they didn't help.

Comment 1 Michael Monreal 2010-06-04 09:54:28 UTC
The live CD is i686 just like the host system.

Comment 2 Michael Monreal 2010-06-04 10:00:55 UTC
I now tried to boot the latest bfo.iso and it hangs after "Probing EDD (edd=off to disable)... OK"

Comment 3 Cole Robinson 2010-06-09 15:28:22 UTC
Does the CD boot on a physical machine? How about:

qemu-system-x86 -cdrom ISO    and
qemu-kvm -cdrom ISO

Can you provide sudo virsh dumpxml $VMNAME ?

Comment 4 Michael Monreal 2010-06-09 19:24:53 UTC
qemu-system-x86_64 -cdrom f13.iso   =>   works but very slow
qemu-kvm -cdrom f13.iso   =>   works and is fast

So I guess we can rule out Qemu or KVM as the problem.

I'll attach the XML in a minute

Comment 5 Michael Monreal 2010-06-09 19:28:27 UTC
Created attachment 422663 [details]
sample vm config xml

Comment 6 Michael Monreal 2010-07-28 09:27:26 UTC
I tried about every stable and testing update of the virt* stack and it's still all the same. Things work fine from the console using qemu-kvm directly, but the virt* tools seem to be horribly broken in F13 :(

Currently installed packages:

virt-manager-0.8.4-1.fc13.noarch
python-virtinst-0.500.3-2.fc13.noarch
libvirt-python-0.8.2-1.fc13.i686
libvirt-client-0.8.2-1.fc13.i686
python-virtkey-0.50-6.fc12.i686
libvirt-0.8.2-1.fc13.i686

Comment 7 Cole Robinson 2010-07-28 13:05:34 UTC
Hmm, can you pull python-virtinst from updates testing, and recreate the livecd VM? I'll try to reproduce this.

If you can still reproduce after the update, please attach the new XML. Thanks.

Comment 8 Michael Monreal 2010-07-28 15:25:24 UTC
(In reply to comment #7)
> Hmm, can you pull python-virtinst from updates testing, and recreate the livecd
> VM? I'll try to reproduce this.

Wow... looks like I missed a testing update for once and this one fixed the problem :)

At least I can boot F13 and Ubuntu 10.04 live isos just fine again now, so I guess we can close this.


Note You need to log in before you can comment on or make changes to this bug.