Bug 600258 - Missing SystemTap Beginners Guide
Summary: Missing SystemTap Beginners Guide
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: Petr Muller
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-04 09:57 UTC by Mark Wielaard
Modified: 2016-09-20 02:06 UTC (History)
3 users (show)

Fixed In Version: systemtap-1.2-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:45:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Wielaard 2010-06-04 09:57:48 UTC
Description of problem:

The SystemTap Beginners Guide is missing.

Version-Release number of selected component (if applicable):

systemtap-1.2-3.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Look for /usr/share/doc/systemtap-1.2/SystemTap_Beginners_Guide*

Actual results:

Nothing there.

Expected results:

PDF and HTML versions of the guide.

Additional info:

The spec file disables publican support, but publican is now available in the optional repository, so it should be enabled to generate the documentation.

Comment 2 RHEL Product and Program Management 2010-06-07 16:09:37 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Frank Ch. Eigler 2010-06-21 20:34:21 UTC
(In reply to comment #0)

> The spec file disables publican support, but publican is now available in the
> optional repository, so it should be enabled to generate the documentation.    

Unfortunately, publican is only available on i686/x86-64, since java is absent
on ppc64/s390x.  I guess on x86* only we could build docs.

Comment 6 Petr Muller 2010-08-20 13:17:00 UTC
# ls /usr/share/doc/systemtap-1.2/SystemTap_Beginners_Guide*
/usr/share/doc/systemtap-1.2/SystemTap_Beginners_Guide.pdf

/usr/share/doc/systemtap-1.2/SystemTap_Beginners_Guide:
appe-Publican-Revision_History.html  images                          sect-RedHat-We_Need_Feedback.html
arrayoperators.html                  index.html                      syscallsbyprocpidsect.html
arrayops-aggregates.html             inodewatch2sect.html            SystemTap_Beginners_Guide-Preface.html
arrayops-conditionals.html           inodewatchsect.html             systemtapscript-handler.html
arrayops-deleting.html               introduction.html               threadtimessect.html
arrayops-foreach.html                intro-systemtap-vs-others.html  timeoutssect.html
arrayops-increment.html              iotimesect.html                 topsyssect.html
arrayops-readvalues.html             ix01.html                       traceio2sect.html
associativearrays.html               mainsect-disk.html              traceiosect.html
commandlineargssect.html             mainsect-profiling.html         understanding-how-systemtap-works.html
Common_Content                       paracallgraph.html              understanding-tapsets.html
cross-compiling.html                 references.html                 useful-systemtap-scripts.html
errors.html                          runtimeerror.html               using-systemtap.html
futexcontentionsect.html             scriptconstructions.html        using-usage.html
handlerconditionalstatements.html    scripts.html


on i686 and x86_64 as described in comment 3. Moving to VERIFIED.

Comment 7 releng-rhel@redhat.com 2010-11-10 21:45:28 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.