Bug 600259 - [abrt] crash in spi_atk_bridge_exit_func callbacks from atexit
Summary: [abrt] crash in spi_atk_bridge_exit_func callbacks from atexit
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:13bf3b8d4440b5173b69e06ec5f...
Keywords:
: 640314 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-04 10:03 UTC by Bruce vaNorman
Modified: 2011-04-05 10:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 10:32:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (32.29 KB, text/plain)
2010-06-04 10:03 UTC, Bruce vaNorman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 563546 None None None Never

Description Bruce vaNorman 2010-06-04 10:03:13 UTC
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer file:///home/bvn/my/Documents/office%20migration%20project/2010%20bamboo%20touch%20log.odt
comment: I don't know what I did. I just finished a forum posting and was shutting down the open windows (just prior to a re-boot back to FC11) when I noticed this.
component: openoffice.org
crash_function: Application::GetSolarMutex
executable: /usr/lib/openoffice.org3/program/swriter.bin
global_uuid: 13bf3b8d4440b5173b69e06ec5f8adaa62fb10e1
kernel: 2.6.33.5-112.fc13.i686.PAE
package: openoffice.org-writer-1:3.2.0-12.23.fc13
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 Bruce vaNorman 2010-06-04 10:03:15 UTC
Created attachment 421181 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-06-04 10:28:06 UTC
Accessibility is enabled, and on shutdown there was a crash. Of course that solarmutex is gone by the time the shutdown stuff shows up.

Comment 3 Caolan McNamara 2010-06-04 14:43:42 UTC
Hmm, I guess we could stuff something into atk_object_wrapper_finalize to not release anything if we're already past exit, and layer more horrors on horrors.

Comment 4 Caolan McNamara 2010-06-28 07:54:09 UTC
I don't think that explicitly calling gnome_accessibility_module_init/gnome_accessibility_module_shutdown would affect spi_atk_bridge_exit_func being registered as an atexit handler, and continuing to trundle around the place at a fairly arbitrary exit point

Comment 5 Caolan McNamara 2010-10-05 14:44:28 UTC
*** Bug 640314 has been marked as a duplicate of this bug. ***

Comment 6 Caolan McNamara 2011-04-05 10:32:35 UTC
As far as I can tell, the new gtk2 a11y stack in F15 appears to fix this problem.


Note You need to log in before you can comment on or make changes to this bug.