Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600260 - icons splitted among screens
icons splitted among screens
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nautilus (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
Desktop QE
:
: 719903 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 06:07 EDT by Vladimir Benes
Modified: 2015-03-03 17:49 EST (History)
4 users (show)

See Also:
Fixed In Version: nautilus-2.28.4-19.el6
Doc Type: Bug Fix
Doc Text:
Cause: No desktop folder refresh performed on display size change Consequence: Icons overflew outside the screen when resolution got lowered Fix: Explicit refresh has been placed on screen size changes Result: Icons are visible when screen resolution is lowered
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:24:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nautilus-2.28.4-screen-size-refresh.patch (603 bytes, patch)
2012-03-02 08:42 EST, Tomáš Bžatek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0914 normal SHIPPED_LIVE nautilus bug fix update 2012-06-19 16:46:27 EDT

  None (edit)
Description Vladimir Benes 2010-06-04 06:07:28 EDT
Description of problem:
when I change resolution from 1440x900 while I have 1280x1024 external screen connected. My icon are moved partly to the other monitor.. Don't know if this is the desired behaviour or just a bug

Version-Release number of selected component (if applicable):
xorg-x11-server-utils-7.4-15.el6.x86_64
metacity-2.28.0-15.el6.x86_64
nautilus-2.28.4-10.el6.x86_64

How reproducible:


Steps to Reproduce:
1.connect two monitors
2.lower resolution to 800x600 on primary one

  
Actual results:
icons are splitted among screens

Expected results:
they should stay on first or should be moved to second one

Additional info:
Comment 1 Vladimir Benes 2010-06-04 06:10:17 EDT
it also happens when you move the smaller monitor to primary position.. the screen size is not recalculated and the rest of the screen (icons on the left) are shown on the second monitor
Comment 2 RHEL Product and Program Management 2010-06-04 06:23:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Owen Taylor 2010-06-04 06:55:24 EDT
No obvious connection to Metacity, reassigning to Nautilus.
Comment 4 RHEL Product and Program Management 2010-07-15 10:19:41 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Tomáš Bžatek 2011-01-19 11:46:45 EST
Not sure what should be the designed behaviour here. I guess we never really thought about it.
Comment 7 Tomáš Bžatek 2011-12-13 10:00:14 EST
(In reply to comment #1)
> it also happens when you move the smaller monitor to primary position.. the
> screen size is not recalculated and the rest of the screen (icons on the left)
> are shown on the second monitor

In dualmonitor setup, is it possible to move the icons to the second screen? I wonder what happens when you lower the resolution enough (for the whole desktop) - do the icons overflow of the screen or just wrap up?
Comment 8 Cosimo Cecchi 2011-12-16 04:23:02 EST
(In reply to comment #5)
> Not sure what should be the designed behaviour here. I guess we never really
> thought about it.

My two cents:

I would expect icons to always "naturally" reflow across the available area.
For example:
- you have a 1280x1024 primary display full of icons
- you attach another 1280x1024 external display and lower the resolution of the primary one to 800x600
- icons should still fill the 800x600 area, but those in excess should start filling the secondary display; the principle here is it's worse to lose the icon completely (i.e. no access to a document unless you browse ~/Desktop in a normal window) than losing a custom icon position or spatial memory.
Comment 9 Tomáš Bžatek 2011-12-19 12:28:58 EST
It looks I'm hitting a different bug - say I have two 1280x1024 screens, when I lower the primary monitor resolution, nautilus moves all icons to the bigger screen. Restoring the original resolution moves icons back on primary monitor. Could be a WM issue since my terminal has moved to the second screen as well - some kind of window rearrangement to another screen having the closest dimensions to the original. Weird.

Anyway I confirm the original issue, I've just placed an icon to the outer edge of the secondary screen, lowered resolutions of both screens and the icon got lost.

When I restart nautilus, dimensions of the root window (the desktop) is retrieved properly and icons are re-arranged. So what's missing here is the handler for screen-size change.
Comment 10 Tomáš Bžatek 2011-12-19 12:30:25 EST
Hitting F5 (refresh) on the desktop will rearrange icons properly as well. This should be an easy fix.
Comment 12 Tomáš Bžatek 2012-01-10 14:02:51 EST
*** Bug 719903 has been marked as a duplicate of this bug. ***
Comment 14 Tomáš Bžatek 2012-03-02 08:42:54 EST
Created attachment 567067 [details]
nautilus-2.28.4-screen-size-refresh.patch

This patch triggers a desktop directory refresh when screen size changes which also rearranges all icons to be visible.
Comment 15 Tomáš Bžatek 2012-03-02 12:50:26 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: No desktop folder refresh performed on display size change

Consequence: Icons overflew outside the screen when resolution got lowered

Fix: Explicit refresh has been placed on screen size changes

Result: Icons are visible when screen resolution is lowered
Comment 18 errata-xmlrpc 2012-06-20 10:24:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0914.html

Note You need to log in before you can comment on or make changes to this bug.