Bug 60029 - iostat inflates times by a factor of 10
iostat inflates times by a factor of 10
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sysstat (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 01:29 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 17:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-19 01:29:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
The code for reading extended statistics in iostat seems to be out of sync with
the sard patch. iostat assumes that the time values in /proc/partitions are in
ticks.  This was true in the early versions of sard patch, but starting with
sard-0.5, the values are converted to milliseconds.  iostat performs a second
"conversion," inflating the values by a factor of 10.  This affects the columns
avqu-sz, await, svctm, and %util.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.iostat -x -d [ <device> ]
2.
3.
	

Actual Results:  Device:  rrqm/s wrqm/s   r/s   w/s  rsec/s  wsec/s avgrq-sz
avgqu-sz   await  svctm  %util
hdb        0.00   0.00  0.00  0.00    0.00    0.00     2.00     0.00  100.00
100.00   0.00

Expected Results:  The corresponding line from /proc/partitions shows:

major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse
running use aveq
   3    64    6346368 hdb 2 0 4 20 0 0 0 0 0 20 20

The times are in milliseconds (known from kernel source)
The disk had two read requests that were serviced in 20ms.
The average wait time and service time should be 10.00, not 100.00.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-02-28 18:30:54 EST
Is this still a problem with 4.0.3-1 from http://people.redhat.com/teg/sysstat/?

(put there for other reasons, so I might as well find out :)
Comment 2 Trond Eivind Glomsrxd 2002-03-25 14:21:22 EST
Ping?
Comment 3 Mike A. Harris 2002-11-10 23:15:06 EST
Since Trond requested packages to be tested over 8 months ago, and got
no response, and no response on a ping a month later, I'm closing this
bug and assuming that it is fixed and working properly, either with
7.2 erratum (if any), or with a newer version of Red Hat Linux.

If the problem still occurs in Red Hat Linux 7.2, it will not be addressed
at this time, however if it occurs in Red Hat Linux 8.0 fully up2date,
feel free to reopen the report and update it to point to 8.0.

Assuming it is working in CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.