Bug 60032 - Overriding MAC address
Overriding MAC address
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 01:44 EST by Bill McCarty
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill McCarty 2002-02-19 01:44:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
The RHL documents don't explain how to configure the /etc/sysconfig/network-
scripts/ifcfg-eth? files to override the MAC address of network adapters. The 
scripts seem not to work properly but, without documentation, I can't be sure 
that I'm modifying them correctly. It's necessary to be able to override MAC 
addreses because some major manufacturers of network adapters seem to be unable 
to avoid assigning duplicate MAC addresses. The systems in question are servers 
and therefore don't have X installed; so, using netconfig isn't an attractive 
option. Moreover, I see a bug report claiming that netconfig doesn't seem to 
work right either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Search documentation for explanation of /etc/sysconfig/network-scripts/ifcfg-
eth? and how those scripts are used by /etc/sysconfig/network-scripts/ifup 
and /etc/sysconfig/network-scripts/ifdown.

	

Actual Results:  I found no explanation. I then proceeded to debug the related 
scripts, without succeeding in understanding how they SHOULD work in this 
situation. They appear NOT to work. But, without documentation, I can't draw 
any reliable conclusion in that regard.

Expected Results:  I expected to find a list of the environment variables used 
in these scripts and the functions associated with those variables, including 
examples for common situations, including the need to override a MAC address.

Additional info:

Workaround is to add an ifconfig command to /etc/rc.d/rc.sysinit. But, that's 
not how this should work, is it? Based on my study of 
the /etc/sysconfig/network-scripts/ifup script, it is clearly intended to 
handle overriding of MAC addresses.

Since that script is part of the initscripts package, I filed this bug report 
against initscripts, rather than some more obviously related component.
Comment 1 Christopher McCrory 2002-03-18 13:26:28 EST
in /etc/sysconfig/network-scripts/ifcfg-eth0

MACADDR=00:50:54:C0:FF:EE

will change the MAC address


Comment 2 Bill McCarty 2002-03-25 13:54:11 EST
Well, my hope was that specifying MACADDR would change the MAC address. 
However, the code tried to match the specified value with the current actual 
value and terminated when it found the mismatch. 

So, to be frank, I expect that a bug lurks here. But, given the absence of 
documentation, I thought it best to verify exactly how the scripts should work 
before assuming that my way -- and ChrisMcc's -- was correct. At the least, I 
suspect something more is necessary than merely specifying MACADDR.
Comment 3 Bill Nottingham 2005-09-29 15:38:16 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.