Bug 600320 - Unmount error
Unmount error
Status: CLOSED DUPLICATE of bug 509427
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Huff
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 08:47 EDT by Mads Kiilerich
Modified: 2010-07-04 08:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-04 08:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2010-06-04 08:47:06 EDT
I tried to follow the instructions on https://projects.centos.org/trac/livecd/wiki/CreateImage and got the following crash. basearch had to be patched and there might be other problems, but F13 livecd-creator shouldn't crash. 

[root@dev-mk tmp]# service nscd stop
Stopping nscd:                                             [  OK  ]
[root@dev-mk tmp]# setenforce 0
[root@dev-mk tmp]# LANG=C livecd-creator --config=centos-livecd-minimal.ks --fslabel=CentOS-minimal
/usr/lib/python2.6/site-packages/pykickstart/parser.py:673: DeprecationWarning: %packages does not end with %end.  This syntax has been deprecated.  It may be removed from future releases, which will result in a fatal error from kickstart.  Please modify your kickstart file to use this updated syntax.
  warnings.warn(_("%s does not end with %%end.  This syntax has been deprecated.  It may be removed from future releases, which will result in a fatal error from kickstart.  Please modify your kickstart file to use this updated syntax.") % "%packages", DeprecationWarning)
mke2fs 1.41.10 (10-Feb-2009)
...
Setting interval between checks to 0 seconds
Error creating Live CD : Unable to download from repo : Cannot retrieve repository metadata (repomd.xml) for repository: a-base. Please verify its path and try again
umount: /var/tmp/imgcreate-_1AwfW/install_root/var/cache/yum: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 140, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 135, in main
    creator.cleanup()
  File "/usr/lib/python2.6/site-packages/imgcreate/creator.py", line 578, in cleanup
    self.unmount()
  File "/usr/lib/python2.6/site-packages/imgcreate/creator.py", line 554, in unmount
    self._undo_bindmounts()
  File "/usr/lib/python2.6/site-packages/imgcreate/creator.py", line 301, in _undo_bindmounts
    b.unmount()
  File "/usr/lib/python2.6/site-packages/imgcreate/fs.py", line 113, in unmount
    raise MountError("Unable to unmount filesystem at %s" % self.dest)
imgcreate.errors.MountError: Unable to unmount filesystem at /var/tmp/imgcreate-_1AwfW/install_root//var/cache/yum
umount: /var/tmp/imgcreate-_1AwfW/install_root/var/cache/yum: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
Exception imgcreate.errors.MountError: MountError('Unable to unmount filesystem at /var/tmp/imgcreate-_1AwfW/install_root//var/cache/yum',) in <bound method x86LiveImageCreator.__del__ of <imgcreate.live.x86LiveImageCreator object at 0x8cfd3ec>> ignored

livecd-tools-031-1.fc12.1.i686
Comment 1 Julian Aloofi 2010-07-04 08:48:49 EDT

*** This bug has been marked as a duplicate of bug 509427 ***

Note You need to log in before you can comment on or make changes to this bug.