Bug 600356 - virt-manager: doesn't display multiple graphics devices
virt-manager: doesn't display multiple graphics devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 10:35 EDT by Christoph A.
Modified: 2010-09-04 00:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: virt-manager-0.8.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-04 00:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log (4.75 KB, text/plain)
2010-06-10 06:42 EDT, Christoph A.
no flags Details
Output of 'virsh dumpxml $VMNAME' (2.15 KB, text/plain)
2010-06-10 06:45 EDT, Christoph A.
no flags Details

  None (edit)
Description Christoph A. 2010-06-04 10:35:40 EDT
Description of problem:
After activating VNC on a VM (within virt-manager) the VM does not boot anymore.

Version-Release number of selected component (if applicable):
virt-manager-0.8.3-3.fc13.noarch

How reproducible:
100% (trying twice)

Steps to Reproduce:
1. choose a VM
2. go to 'show virtual hardware details'
3. 'Add Hardware'
4. select 'Graphics' -> Forward
5. Check "Listen on all public network interfaces"
6. enter a passwort (or not) -> forward
7. finish
8. try to start vitual machine
  
Actual results:
Error output:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 799, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1256, in startup
    self._backend.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 317, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/1
Could not initialize SDL - exiting

syslog/messages when trying to start VM:
Jun  4 16:22:42 <hostname> kernel: device vnet0 entered promiscuous mode
Jun  4 16:22:42 <hostname> kernel: virbr0: topology change detected, propagating
Jun  4 16:22:42 <hostname> kernel: virbr0: port 1(vnet0) entering forwarding state
Jun  4 16:22:42 <hostname> NetworkManager[1445]: <warn> /sys/devices/virtual/net/vnet0: couldn't determine device driver; ignoring...
Jun  4 16:22:42 <hostname> kernel: virbr0: port 1(vnet0) entering disabled state
Jun  4 16:22:42 <hostname> kernel: device vnet0 left promiscuous mode
Jun  4 16:22:42 <hostname> kernel: virbr0: port 1(vnet0) entering disabled state
Jun  4 16:22:43 <hostname> libvirtd: 16:22:43.064: error : qemudReadLogOutput:1416 : internal error Process exited while reading console log output: char device redirected to /dev/pts/1#012Could not initialize SDL - exiting#012

Expected results:
VM should boot up.

Additional info:
Guest OS was a Fedora 13 but I guess that doesn't matter.
Comment 1 Cole Robinson 2010-06-09 11:30:18 EDT
Can you provide ~/.virt-manager/virt-manager.log and sudo virsh dumpxml $VMNAME?
Comment 2 Christoph A. 2010-06-10 06:42:45 EDT
Created attachment 422854 [details]
virt-manager.log
Comment 3 Christoph A. 2010-06-10 06:45:00 EDT
Created attachment 422856 [details]
Output of 'virsh dumpxml $VMNAME'
Comment 4 Cole Robinson 2010-06-10 10:47:32 EDT
Ah okay, the issue is that there are multiple VNC devices specified in your XML, which is confusing libvirt/qemu. You can fix this in virt-manager: keep selecting the VNC graphics device and clicking 'Remove' until there are none in the device list, then re-add a VNC device as you had done above.

The issues here are:

- virt-manager should show all attached graphics devices (fixed in updates-testing)
- virt-manager should not allow attaching multiple graphics devices
- libvirt should throw an explicit error if it can't handle the graphics config,
  not just fall back to SDL
Comment 5 Cole Robinson 2010-08-23 15:31:48 EDT
Multiple graphics device listing is fixed upstream now, moving to post.
Comment 6 Fedora Update System 2010-08-25 16:58:59 EDT
virt-manager-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 7 Fedora Update System 2010-08-25 20:53:22 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 8 Fedora Update System 2010-08-31 23:27:44 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 9 Fedora Update System 2010-09-04 00:58:56 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.