Bug 600358 - rpmbuild auto delete the packaged files in BUILDROOT.
rpmbuild auto delete the packaged files in BUILDROOT.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 10:44 EDT by ebird98
Modified: 2010-06-07 21:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 02:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ebird98 2010-06-04 10:44:13 EDT
Description of problem:
There is no %clean/%build section in my .spec files.
but rpmbuild deleted my files in the BUILDROOT when I used "rpmbuild -bb".

Version-Release number of selected component (if applicable):
redhat-rpm-config.noarch
rpm.i686            4.8.0-14.fc13   @anaconda-InstallationRepo-201005130056.i386
rpm-build.i686      4.8.0-14.fc13   @anaconda-InstallationRepo-201005130056.i386
rpm-devel.i686      4.8.0-14.fc13   @anaconda-InstallationRepo-201005130056.i386
rpm-libs.i686       4.8.0-14.fc13   @anaconda-InstallationRepo-201005130056.i386
rpm-python.i686     4.8.0-14.fc13   @anaconda-InstallationRepo-201005130056.i386
rpmdevtools.noarch  7.8-1.fc13      @anaconda-InstallationRepo-201005130056.i386


Steps to Reproduce:
1.rpmbuild a binary RPM. (BIN files has build already, so use "-bb" switch)
  
Actual results:
All of the files packaged has been deleted.

Expected results:
Should not delete any files, when NO %clean/%build section in my .spec file.
Comment 1 Jeff Johnson 2010-06-05 08:50:39 EDT
Yes. BUILDROOT is now configured and managed as a build system
element, not a per-package option.

Running "rpmbuild -bi foo.spec" will build and install (but not remove)
the files in the buildroot.
Comment 2 Panu Matilainen 2010-06-07 02:16:57 EDT
This is indeed the intended behavior and not a bug.
Comment 3 ebird98 2010-06-07 21:47:29 EDT
Thanks,I got a way to KEEP the files.:)
So different between 4.8 and 4.6...

Note You need to log in before you can comment on or make changes to this bug.