Bug 600395 - allow_kill does not prevent eviction via disk
allow_kill does not prevent eviction via disk
Status: CLOSED DUPLICATE of bug 602731
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 11:54 EDT by Lon Hohberger
Modified: 2011-01-25 10:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-25 10:11:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2010-06-04 11:54:13 EDT
Description of problem:

When you set allow_kill to 0, the qdiskd master no longer asks CMAN to evict/fence the presumed-dead host.  However, it will still write an eviction notice to disk.  If the presumed-dead host reads in the eviction notice, it will reboot itself.

If storage is flaky (for example, exhibiting long delays for I/O), users may wish to disable all qdiskd failure-recovery actions in order to sabilize the cluster - this includes both CMAN *and* disk eviction.

Today, the former is possible, but the latter is not.

We need the ability to disable disk-based eviction.
Comment 1 Lon Hohberger 2010-06-04 11:56:07 EDT
There are two possibilities:

1) Simply do not write eviction notices, or

2) Do not act on eviction notices by reboot -- instead, restart qdiskd with a new incarnation #.
Comment 4 Lon Hohberger 2011-01-25 10:11:50 EST

*** This bug has been marked as a duplicate of bug 602731 ***

Note You need to log in before you can comment on or make changes to this bug.