Bug 600425 - git-1.7.1-1 fails to build in mock
git-1.7.1-1 fails to build in mock
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 12:49 EDT by Garrett Holmstrom
Modified: 2013-01-10 05:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 16:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log for git-1.7.1-1 (193.07 KB, text/x-log)
2010-06-04 12:49 EDT, Garrett Holmstrom
no flags Details

  None (edit)
Description Garrett Holmstrom 2010-06-04 12:49:31 EDT
Created attachment 421293 [details]
build.log for git-1.7.1-1

Description of problem:
make doc invokes xmlto, which attempts to grab the Docbook DTD from the Internet as it processes Git's documentation.  Since builds can't/shouldn't access the Internet it fails to retrieve this DTD, causing xmlto to die since it can't validate the XML.


Version-Release number of selected component (if applicable):
git-1.7.1-1


How reproducible:
mock git-1.7.1-1.fc14.src.rpm

  
Actual results:
Build fails (see attached build.log)
Comment 1 Todd Zullinger 2010-06-04 15:54:46 EDT
This WORKSFORME for both Fedora and EPEL builds.  It also works in koji:

    http://koji.fedoraproject.org/koji/taskinfo?taskID=2230511

That's an EL-5 build.  The problem you're seeing looks like what happens when there is a missing dependency.  You might want to compare your root.log to the one in the koji build to see if you're missing something or pulling difference versions from some 3rd party repository.

I /think/ I saw a patch on the git list from another distro maintainer to force the doc building to pass the -nonet option, so it won't ever try to fall back to using the network.  I'm not sure if that was included or not.  But if you have the right tools installed, it should never need to try the network versions.
Comment 2 Garrett Holmstrom 2010-06-04 16:05:41 EDT
I'll take your word for it; I'm probably doing something strange, then.
Comment 3 Todd Zullinger 2010-06-04 16:10:35 EDT
In the interim, if you want some packages built from a known srpm, you could do a koji scratch build of the rawhide package:

    koji build --scratch dist-5E-epel git-1.7.1-1.fc14.src.rpm

Note You need to log in before you can comment on or make changes to this bug.