Bug 60044 - undelete command shows empty screen
undelete command shows empty screen
Status: CLOSED WONTFIX
Product: Red Hat Powertools
Classification: Retired
Component: safedelete (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 07:02 EST by Peter Englmaier
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 07:29:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Englmaier 2002-02-19 07:02:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Running 'undelete' returns an empty screen. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.delete a file with safedelete
2.run 'undelete'

	

Actual Results:  xterm display is empty (press control-C to exit).
Same result on text-console.


Expected Results:  List of deleted files.


Additional info:

I found this bug earlier and there was a bug report which never was
fixed (but disappeared from bugzilla). I think it started with Redhat version
6.0, but I'm not sure. Earlier versions worked fine. I believe it is a problem
with the 'stdin/stdout' setup. Ncurses assumes certain settings (buffering), etc.
I have a patch which partially fixes the problem (see below).I say partially,
because in my opinion the program 'safedelete' is correct, something else is
broken (terminal emulation or ncurses). However, the fix won't break safedelete
in other circumstances, so I would like to ask you to apply the patch in future
releases.

diff -uNr safedelete-1.3-orig/undelete.c safedelete-1.3/undelete.c
--- safedelete-1.3-orig/undelete.c	Tue Feb 19 09:46:18 2002
+++ safedelete-1.3/undelete.c	Tue Feb 19 11:22:54 2002
@@ -1832,6 +1832,7 @@
       ReleaseLock();
       return 1;
     }
+    refresh();
 
 /* We need at least a 24x80 screen to do our thing */
Comment 1 Bernhard Rosenkraenzer 2002-02-19 07:47:43 EST
Since this is not bad enough to require an errata and Powertools has been discontinued, 
there's no release in which we can fix this.

Note You need to log in before you can comment on or make changes to this bug.