Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 600468 - Segfault in krb5_child
Segfault in krb5_child
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Stephen Gallagher
Chandrasekar Kannan
:
Depends On:
Blocks: 579775
  Show dependency treegraph
 
Reported: 2010-06-04 15:07 EDT by Sumit Bose
Modified: 2015-01-04 18:42 EST (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.2.0-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sumit Bose 2010-06-04 15:07:23 EDT
Description of problem:
The Kerberos child dies with a segmentation fault.

Version-Release number of selected component (if applicable):
1.2

How reproducible:
It is not eays to reproduce because it depends on how the memory in initialized.
  
Additional info:
Then pam_data structure of krb5_child is not initialized properly especially the pointer to the response items.
Comment 5 Gowrishankar Rajaiyan 2010-07-28 14:41:28 EDT
Unable to reproduce this.
VERIFIED in version sssd-1.2.1-21.el6.
Comment 6 releng-rhel@redhat.com 2010-11-10 16:39:54 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.