Bug 600469 - list-haddrives fails with "unrecognized disk label" error
list-haddrives fails with "unrecognized disk label" error
Status: CLOSED DUPLICATE of bug 586410
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 15:10 EDT by Paul Waterman
Modified: 2010-06-04 15:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 15:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Waterman 2010-06-04 15:10:29 EDT
Description of problem:

When I attempt to run "list-harddrives" on a Fedora 13 system during a kickstart (either manually from the VT 2 or from a kickstart %pre script), it generates the following error:

# list-harddrives
Traceback (most recent call last):
  File "/usr/bin/list-harddrives", line 39 in <module>
  File "/usr/bin/list-harddrives", line 28, in main
    disk = parted.Disk(dev)
  File "<string>", line 2, in __init__
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 51, in __init__
    self.__disk = _ped.Disk(device.getPedDevice())
_ped.DiskLabelException: /dev/sr0: unrecognised disk label

All testing was performed on a vanilla VMware Server virtual machine with a single virtual SCSI drive (SCSI 0:0) on a virtual LSI Logic SCSI controller 0.

This error occurred when (a) the virtual disk had a previous RHEL 5.4 image on it, (b) the virtual disk had a previous Fedora 13 image on it, and (c) even after the first 200MB of the virtual disk had been zeroed via "dd if=/dev/zero of=/dev/sda bs=1M count=200".

I have not had the opportunity to test this on a physical machine.

Version-Release number of selected component (if applicable):
Anaconda 13.42

How reproducible:
Always

Steps to Reproduce:
1. Begin a kickstart in Fedora 13
2. Switch to virtual terminal 2 via ALT-F2
3. Run "list-harddrives" at the command prompt.
  
Actual results:
Error as shown above

Expected results:
A list of the available hard drives devices on the system.

Additional info:
Comment 1 Chris Lumens 2010-06-04 15:15:05 EDT

*** This bug has been marked as a duplicate of bug 586410 ***

Note You need to log in before you can comment on or make changes to this bug.