Bug 600479 - corosync won't shutdown with firewall enabled
Summary: corosync won't shutdown with firewall enabled
Status: CLOSED DUPLICATE of bug 599327
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On: 557513 576000
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-04 19:29 UTC by Steven Dake
Modified: 2016-04-26 14:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 576000
Environment:
Last Closed: 2010-09-30 16:26:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven Dake 2010-06-04 19:29:21 UTC
+++ This bug was initially created as a clone of Bug #576000 +++

Description of problem:

When setting up and you forget your firewall on (like I did).

totem gets stuck in the gather state:
Mar 23 09:39:16 corosync [TOTEM ] entering GATHER state from 3.
Mar 23 09:39:18 corosync [TOTEM ] The consensus timeout expired.
...

Our current shutdown relies on the ability to send a token.
It hooks into sched_work() which gets fired on token_send.
In the above state we are not in a state to send a token
so we can't shutdown.

We probably need to check that the totem state is operational
before calling schedwrk_create(), if not call
service_exit_schedwrk_handler() directly.


Version-Release number of selected component (if applicable):
trunk

How reproducible:
100%

Steps to Reproduce:
1.enable firewall (default one)
2.service corosync restart
3.
  
Actual results:
it will never shutdown

Expected results:
shutdown quickly

Additional info:

Comment 3 Steven Dake 2010-09-30 16:26:55 UTC

*** This bug has been marked as a duplicate of bug 599327 ***


Note You need to log in before you can comment on or make changes to this bug.