Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600488 - Some package indications don't get to the console
Some package indications don't get to the console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
Development
All Linux
urgent Severity high
: 2.0
: ---
Assigned To: Ken Giusti
MRG Quality Engineering
:
: 602139 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 15:49 EDT by Justin Ross
Modified: 2014-07-01 08:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-qmf-0.9.1073306-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 17:06:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (28.91 KB, patch)
2010-07-07 14:25 EDT, Ken Giusti
no flags Details | Diff

  None (edit)
Description Justin Ross 2010-06-04 15:49:12 EDT
The mrg31 grid is publishing objects under the com.redhat.grid package.  The console, however, never receives a com.redhat.grid package indication.

This code, if run on mrg31, reproduces the problem:

  #!/usr/bin/python

  from qmf.console import *
  import time

  s = Session()
  s.addBroker()

  time.sleep(5)

  print s.getPackages()

qpid-tool, however, does see the com.redhat.grid package.

This problem prevents cumin from making any method calls.
Comment 1 Ken Giusti 2010-06-07 09:55:52 EDT
Running on MRG31:

qpid: list
Summary of Objects by Type:
    Package                 Class         Active  Deleted
    =======================================================
    com.redhat.grid         scheduler     8       0
    org.apache.qpid.broker  broker        1       0
    org.apache.qpid.broker  vhost         1       0
    org.apache.qpid.broker  exchange      8       0
    org.apache.qpid.broker  queue         604     0
    org.apache.qpid.broker  binding       2396    0
    com.redhat.sesame       sysimage      8       0
    com.redhat.grid         collector     1       0
    org.apache.qpid.broker  connection    596     0
    com.redhat.grid         slot          453     0
    com.redhat.grid         negotiator    1       0
    org.apache.qpid.broker  system        1       0
    com.redhat.grid         submitter     1       0
    com.redhat.rhm.store    store         1       0
    org.apache.qpid.broker  subscription  604     0
    com.redhat.grid         master        9       0
    org.apache.qpid.broker  session       590     0
    org.apache.qpid.broker  agent         6       0
qpid: quit
Exiting...
[root@mrg31 kgiusti]# ./bz600488.py 
['com.redhat.rhm.store', 'com.redhat.sesame', 'org.apache.qpid.broker', 'mrg.grid', 'com.redhat.grid.config']
[root@mrg31 kgiusti]# 


Note the bz600488.py script (reproducter from above comment) gives "mrg.grid" and "com.redhat.grid.config" - which DO NOT appear via qpid-tool.
Comment 2 Ken Giusti 2010-06-10 14:02:42 EDT
Justin has implemented a work around for this, dropping mrg-blocker flag.
Comment 3 Ken Giusti 2010-07-07 14:25:01 EDT
Created attachment 430146 [details]
proposed fix

Proposed fix:

1) add "schema timestamp" to agent heartbeat - update when agent's schema status changes.
2) console detects changes to schema timestamp, sends query for all schema_ids to the agent.
3) agent supports query for schema_id's
4) console stores all known schema ids to schema cache, does not fetch associated schema definition until needed (unchanged).
Comment 4 Ken Giusti 2010-07-12 16:40:59 EDT
Pushed fix upstream.  

Committed revision 963479
Comment 5 Ken Giusti 2010-07-19 11:04:05 EDT
Bug found with last commit - fixed upstream:

http://svn.apache.org/viewvc?rev=964155&view=rev

applied against original commit (http://svn.apache.org/viewvc?rev=963479&view=rev)
Comment 6 Ken Giusti 2010-07-22 17:52:31 EDT
Change is high-risk for 1.3. The workaround has been implemented and well tested.  Push off to next release.
Comment 7 Jeff Needle 2010-11-05 06:50:21 EDT
If the change was high risk for 1.3, what makes it a viable candidate for 1.3.0.1?
Comment 8 Ted Ross 2010-11-08 14:54:29 EST
The risk was more related to the the timing of the 1.3 release and less about the content of the change.

jross: Is the workaround still sufficient for this or is there a need to include this bug in the errata?
Comment 9 Ken Giusti 2010-11-24 09:59:44 EST
Eng Note: the following bugfix also applies to this fix:

http://svn.apache.org/viewvc?view=revision&revision=981682

Be sure to merge this patch along with the others when/if merging this bug.
Comment 10 Matthew Farrellee 2011-10-27 12:36:08 EDT
When/where was this released?
Comment 11 Justin Ross 2011-11-14 15:36:37 EST
The fix was released with python-qpid-0.10-1, in mrg 2.0.
Comment 13 Stanislav Graf 2011-11-16 06:31:29 EST
[Reproduce on RHEL5 x86_64]

# rpm -q condor condor-qmf qmf qpid-cpp-server python-qmf python-condorutils
python-qpid
condor-7.4.5-0.8.el5
condor-qmf-7.4.5-0.8.el5
qmf-0.7.946106-28.el5
qpid-cpp-server-0.7.946106-28.el5
python-qmf-0.7.946106-14.el5
package python-condorutils is not installed
python-qpid-0.7.946106-15.el5

# qpid-tool
Management Tool for QPID
qpid: list
Summary of Objects by Type:
    Package                 Class         Active  Deleted
    =======================================================
    com.redhat.grid         scheduler     1       0
    com.redhat.grid         slot          2       0
    org.apache.qpid.broker  binding       93      0
    com.redhat.grid         jobserver     1       0
    com.redhat.grid         master        1       0
    com.redhat.sesame       sysimage      1       0
    org.apache.qpid.broker  broker        1       0
    com.redhat.grid         negotiator    1       0
    org.apache.qpid.broker  subscription  21      0
    org.apache.qpid.broker  connection    9       0
    org.apache.qpid.broker  session       9       0
    org.apache.qpid.broker  queue         22      0
    org.apache.qpid.broker  exchange      8       0
    org.apache.qpid.broker  vhost         1       0
    org.apache.qpid.broker  system        1       0
    com.redhat.grid         collector     1       0
qpid: schema
QMF Classes:
    Package                 Name                  Kind
    ======================================================
    com.redhat.grid         scheduler             object
    com.redhat.grid         jobserver             object
    com.redhat.grid         collector             object
    com.redhat.grid         master                object
    com.redhat.grid         negotiator            object
    com.redhat.grid         slot                  object
    org.apache.qpid.broker  vhost                 object
    org.apache.qpid.broker  bridge                object
    org.apache.qpid.broker  binding               object
    org.apache.qpid.broker  connection            object
    org.apache.qpid.broker  subscription          object
    org.apache.qpid.broker  broker                object
    org.apache.qpid.broker  system                object
    org.apache.qpid.broker  queue                 object
    org.apache.qpid.broker  link                  object
    org.apache.qpid.broker  exchange              object
    org.apache.qpid.broker  session               object
    org.apache.qpid.broker  managementsetupstate  object
    org.apache.qpid.broker  agent                 object
    com.redhat.sesame       sysimage              object
qpid: quit
Exiting...
ecode=0

# python bz600488 
['org.apache.qpid.broker']
ecode=0

NOT all packages from qpid-tool schema/list are in bz602139.py - expect:
['com.redhat.grid', 'org.apache.qpid.broker', 'com.redhat.sesame']
Comment 15 Stanislav Graf 2011-11-16 07:36:03 EST
*** Bug 602139 has been marked as a duplicate of this bug. ***
Comment 16 Stanislav Graf 2011-11-16 07:37:00 EST
Summary:

MRG2 RHEL5 i386/x86_64
python-qpid-0.10-1.el5
fixed, VERIFIED

MRG2 RHEL6 i386/x86_64
python-qpid-0.10-1.el6
fixed, VERIFIED

MRG1 RHEL5 i386/x86_64
python-qpid-0.7.946106-15.el5
not-fixed, FAILED
Comment 17 Stanislav Graf 2011-11-17 05:16:47 EST
Fixed In Version: python-qmf-0.9.1073306-1
According to Bug 602139, comment 7 - MRG1 has python-qmf-0.7.946106-14.el5

Comment 11 : fixed in python-qpid-0.10-1
According to Bug 602139, comment 6 - MRG2 has python-qpid-0.10-1.el6
According to Bug 602139, comment 5 - MRG2 has python-qpid-0.10-1.el5

Note You need to log in before you can comment on or make changes to this bug.