Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 600506 - PPC64 version can't install gcc
PPC64 version can't install gcc
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
ppc64 Linux
low Severity high
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 16:51 EDT by John Stewart
Modified: 2010-06-17 17:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 17:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The initial file attachment failed. Trying again. (24.50 KB, application/msword)
2010-06-04 16:54 EDT, John Stewart
no flags Details

  None (edit)
Description John Stewart 2010-06-04 16:51:41 EDT
Description of problem: Please see attached doc file for all the info below.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Stewart 2010-06-04 16:54:47 EDT
Created attachment 421351 [details]
The initial file attachment failed. Trying again.

The initial file attachment failed. Trying again.
Comment 3 Bill Nottingham 2010-06-04 17:05:24 EDT
Extracted from attachment.

...

Prior to testing the PPC RHEL6 installs I installed RHEL6 (20100414) on Intel x86_64 and everything went as expected and seems to be working fine so far.

PPC RHEL6 Beta: 20100414

I installed RHEL6 Beta for PPC. The install didn’t ask for any packages to install or for any Eth config settings, or for any RHEL install key. As soon as I selected the drive to load to it started installing a default set of packages. Afterwards, ifconfig failed to setup the Eth. I had to edit the /etc/sysconfig/… network files to manually configure my Eth connection. I got this working.

I then setup NIS, but “authconfig”errored with fingerprint support missing. I found the missing rpm and installed it, but it still complained, so I turned off that feature in authconfig and it behaved. However NIS functionality still didn’t work. I had to add several packages that weren’t installed. I yum added autofs, ypbind, and nfs-utils. Now I could get NIS to function correctly.

Next I tried to build a small application but “make” was missing. I yum installed make and then gcc was missing. I tried to yum install gcc, but there was a conflict. gcc wanted an older version of glibc than the RHEL6 install added:
Error: Package: glibc-devel-2.11.1-1.10.el6.ppc64 (rhel-beta)
           Requires: glibc = 2.11.1-1.10.el6
           Installed: glibc-2.11.90-20.el6.ppc (installed)

It wouldn’t let me remove or downgrade glibc to 2.11.1-1.10.el6, and gcc wouldn’t install with the newer glibc in place. I can’t use this system until I can build on it, and I can’t build on it until I resolve this gcc install issue!!!

I later downloaded and installed a newer version of RHLE6: “snapshot 6”.

PPC RHLE6 Snapshot 6: 20100527.2

The install was the same as the previous PPC install above. I had to manually setup the Eth config the same way via editing system files.

I also ran into the same issues with the NIS configuration. However unlike last time, yum couldn’t even install the packages it was missing:
[root@lppb116 Packages]# yum install autofs
Loaded plugins: rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package autofs available.
Error: Nothing to do

I got the same message for every package I attempted to install. 

I decided to look at gcc. I manually copied over the rpm packages from the install DVD to this new system and tried to install gcc using rpm. It errored, complaining about dependencies.

This newer version is in worse shape (from what I ran across) that the earlier version.

Summary:
Both versions of RHEL6 Beta for PPC that I tried are unusable in their current condition to have people log into them and do simple gcc builds.

Are there any workarounds to make this basic functionality work correctly so that we could begin to test things using this RHEL6 OS on PPC hardware?
...
Comment 4 Bill Nottingham 2010-06-04 17:17:48 EDT
Please file the authconfig issues separately.

As to installation of packages, for later snapshots you'll have to edit your yum configuration to point to wherever you have mirrored it to/downloaded it from (or install packages from the CD). What dependency errors did you get?
Comment 5 RHEL Product and Program Management 2010-06-07 16:43:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Jakub Jelinek 2010-06-08 05:41:33 EDT
This doesn't seem to have anything with gcc, perhaps some bug in which multilib subpackages of glibc were shipped in that particular snapshot.  That would be an rel-eng bug.
Comment 7 Dennis Gregorovic 2010-06-09 16:59:39 EDT
I took a look at the trees and couldn't find dependency issues.  Bill is correct that installs from trees after Beta 1 will need to update their yum repos to point to the corresponding tree.  John, what are the unresolved dependencies that you're seeing with Snapshot 6?
Comment 8 John Stewart 2010-06-09 17:56:44 EDT
In the older beta PPC version, yum installs worked on my system after the install, but when I tried to install ggc, it errored saying it wanted an older glibc than was packaged with the install (example listed with my initial log of this issue).

With this snapshot 6 version, the yum installs didn't work at all after the install and not being an expert in this area and limited time to research how to do it, I decided to copy the "Packages" rpm files from the install DVD and try to install gcc manually. When I tried this I saw a similar error to the prev yum gcc install attempt using the older beta version, complaining about a glibc version:

Error: Package: gcc-4.4.4-5.el6.ppc64 (/gcc-4.4.4-5.el6.ppc64)
           Requires: glibc-devel >= 2.2.90-12

The Packages folder from the install only has glibc 2.12-1.2. This may not be the same issue as before, but it looked the same to me, where gcc wanted an older version than was available. 

I get the feeling that you believe I won't hit the same gcc install issue as with the older beta if I redirect yum to use my own repo that I populate with the install dvd's "Packages" rpm files. I will try to make some time to ask my friend Google how to accomplish this to try installing gcc with yum and see what happens.
Comment 9 Dennis Gregorovic 2010-06-10 09:17:16 EDT
Please try adding the following to /etc/yum.repos.d/rhel6-beta.repo:

[rhel6]
name=Red Hat Enterprise Linux 6 - $basearch
baseurl=file:///mnt/loop
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

You will need to change '/mnt/loop' in the baseurl above to the path where the DVD is mounted.  It'll probably be something like /media/RHEL_6.0_x86_64_Disc_1
Comment 10 John Stewart 2010-06-10 16:32:21 EDT
I couldn't mount the IBM virtual DVD drive (said it was empty), so I enabled the [rhel-beta] entry with the RH ftp site in rhel6-beta.repo, but this gave me the same dependancy mismatch as before when I tried to install gcc.

I decided to copy the DVD ISO image to my system and mounted it. Then I added your suggested [rhel6] entry and pointed it to my mounted DVD folder. That resolved the issue. I was able to install gcc and the other missing packages I needed.

Thanks for the suggestions.
Comment 11 Bill Nottingham 2010-06-10 17:11:19 EDT
OK, I'm going to close this as WORKSFORME - once the proper repositories are set up, it seems to work OK.

Note You need to log in before you can comment on or make changes to this bug.