Bug 60051 - Sendmail service fails to shutdown on system reboot/halt
Sendmail service fails to shutdown on system reboot/halt
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 10:01 EST by John A. Hull
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 09:29:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John A. Hull 2002-02-19 10:01:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)

Description of problem:
When rebooting or halting a system with Hampton beta 1, the system returns a 
FAILED message when trying to shut down the sendmail service. Sendmail starts 
fine on boot, but does not shut down correctly. Performing a "service sendmail 
stop" at the command line works correctly and stops the service.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install Hampton beta 1
2. Boot the system
3. Give the init 6 or init 0 command
4. Watch as services stop; sendmail will fail
	

Actual Results:  sendmail fails to shut down

Expected Results:  sendmail stops correctly

Additional info:
Comment 1 Yil-Kyu Kang 2002-03-11 15:07:12 EST
Tested with beta2 and recieved expected behavior. Please test again and confirm.
Comment 2 John A. Hull 2002-03-12 17:53:22 EST
Reproduced on Beta 2.
Comment 3 Jay Turner 2002-03-21 09:29:02 EST
I'm not able to replicate this in the lab.  Just to make sure . . . you boot the
system, then after it boots, run 'telinit 6' and sendmail will fail to shutdown.
 Or are you performing other actions between bringing the machine up and
shutting it down?
Comment 4 John A. Hull 2002-03-21 12:51:35 EST
Looks like this has been fixed in Hampton Beta 3. Closing.

Note You need to log in before you can comment on or make changes to this bug.