Bug 600552 - Template files not found by amserverconfig
Template files not found by amserverconfig
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amanda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Görig
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 22:14 EDT by Andrew Kroeger
Modified: 2010-08-17 01:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: amanda-2.6.1p2-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 01:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Kroeger 2010-06-04 22:14:57 EDT
Description of problem:
When attempting to create a base amanda configuration using the amserverconfig utility distributed as part of the F13 release, the template files cannot be found and no configuration is generated.

Version-Release number of selected component (if applicable):
amanda-server-2.6.1p2-3.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install amanda-server and amanda-client
2. Run command "amserverconfig <config_name> --template harddisk --tapedev /data3/amanda/vtapes/<config_name> --mailto root --dumpcycle 1week --runspercycle 7 --tapecycle 16"
  
Actual results:
Receive "ERROR: copy dumptypes failed: No such file or directory".  (My apologies, but this may not be the exact error message.  Now that I have everything configured and working, I lost my scrollback buffer to see the exact message displayed.)

Expected results:
Initial configuration successfully created that I can then customize as needed.

Additional info:
This error is due to an incorrect path definition in the amserverconfig utility - the $templatedir variable is defined based on $amdatadir.  $amdatadir is defined via Amanda::Paths as "/usr/share/amanda", which does not exist.

Based on the amanda-2.6.1p2-example.patch patch included in the SRPM, it appears that the examples were updated to show the template files installed under $(localstatedir)/lib/amanda/template.d ("/var/lib/amanda/template.d") but a similar path update was not made to amserverconfig.
Comment 1 Fedora Update System 2010-08-03 10:54:30 EDT
amanda-2.6.1p2-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/amanda-2.6.1p2-4.fc13
Comment 2 Jan Görig 2010-08-03 10:57:24 EDT
Thank you for your bug report. Problem should be fixed in linked update. Could you test it, please? Thanks.
Comment 3 Fedora Update System 2010-08-05 19:30:47 EDT
amanda-2.6.1p2-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update amanda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/amanda-2.6.1p2-4.fc13
Comment 4 Fedora Update System 2010-08-17 01:32:41 EDT
amanda-2.6.1p2-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.