Bug 600555 - At registration, Satellite report of exhausted entitlements has confusing message
At registration, Satellite report of exhausted entitlements has confusing mes...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Jan Hutař
: EasyFix, Patch
Depends On:
Blocks: sat54-blockers
  Show dependency treegraph
 
Reported: 2010-06-04 22:28 EDT by Xixi
Modified: 2011-11-21 04:44 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-56
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 04:44:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server_token.py.TEST.962563.1.patch (754 bytes, patch)
2010-06-04 22:30 EDT, Xixi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1466 normal SHIPPED_LIVE Red Hat Network Satellite server spacewalk-backend bug fix update 2011-11-21 09:43:48 EST

  None (edit)
Description Xixi 2010-06-04 22:28:20 EDT
Description of problem:
Attempting to register a system under the following conditions:
- with an activation key that specifies Monitoring Entitlements
- no Monitoring Entitlements available
- Registration fails with:

Error Message:
  Registration failed: RHN Software Management service entitlements exhausted
Error Class Code: 91
Error Class Info: Registration token unable to entitle system: maximum membership exceeded

This confuses customer since "Management" sounds like Management entitlements are exhausted, and not the actual (Monitoring) entitlements.

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. See above.

Actual results:
See above.

Expected results:
Clearer error message as not to confuse w/ "Management entitlements".

Additional info:
Comment 1 Xixi 2010-06-04 22:30:07 EDT
Created attachment 421392 [details]
server_token.py.TEST.962563.1.patch

suggested patch (unverified)
Comment 6 Jan Pazdziora 2011-10-17 10:33:23 EDT
Fixed in Spacewalk master, 03eae8bd77ab285b69b26bb5ffa12808a29b77c0. Applied the above fix with minor tweaks as the code in Spacewalk is a bit different.
Comment 7 Michael Mráka 2011-10-26 05:00:08 EDT
Backported to SATELLITE-5.4 as
commit 34e0a39a673983a65d0b182a44398dfc516264ec
    600555 - removing the Management word from the error message because it is not Manag
Comment 12 errata-xmlrpc 2011-11-21 04:44:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1466.html

Note You need to log in before you can comment on or make changes to this bug.