Bug 600667 - can't activate network
can't activate network
Status: CLOSED DUPLICATE of bug 516788
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-05 10:21 EDT by Riku Seppala
Modified: 2010-06-28 16:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 16:30:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-network (45.40 KB, image/png)
2010-06-05 10:21 EDT, Riku Seppala
no flags Details
output of lsmod (2.59 KB, text/plain)
2010-06-15 13:36 EDT, Riku Seppala
no flags Details

  None (edit)
Description Riku Seppala 2010-06-05 10:21:02 EDT
Created attachment 421435 [details]
system-config-network

Maybe related to bug 583113 but this is different computer. Just installed Fedora 13. Maybe I'm missing something important here but this use to work just fine with f12.

[root@localhost network-scripts]# more ifcfg-wlan0 
# Atheros Communications Inc. AR2413 802.11bg NIC
DEVICE=wlan0
HWADDR=00:27:19:E5:4B:1B
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=Wireless
NM_CONTROLLED=yes
USERCTL=yes
PEERDNS=yes
IPV6INIT=no
ESSID=dietyyli
MODE=Auto
RATE=auto
CHANNEL=
[root@localhost network-scripts]# nmcli dev list
GENERAL.DEVICE:                 eth0
GENERAL.TYPE:                   802-3-ethernet
GENERAL.DRIVER:                 r8169
GENERAL.HWADDR:                 6C:F0:49:02:F0:F5
GENERAL.STATE:                  unavailable
CAPABILITIES.CARRIER-DETECT:    yes
CAPABILITIES.SPEED:             10 Mb/s
WIRED-PROPERTIES.CARRIER:       off
GENERAL.DEVICE:                 wlan0
GENERAL.TYPE:                   802-11-wireless
GENERAL.DRIVER:                 ath5k
GENERAL.HWADDR:                 00:27:19:E5:4B:1B
GENERAL.STATE:                  disconnected
CAPABILITIES.CARRIER-DETECT:    no
CAPABILITIES.SPEED:             unknown
WIFI-PROPERTIES.WEP:            yes
WIFI-PROPERTIES.WPA:            yes
WIFI-PROPERTIES.WPA2:           yes
WIFI-PROPERTIES.TKIP:           yes
WIFI-PROPERTIES.CCMP:           yes

Why is the activate button gray? I run system-config-network as root.

btw, usb memory stick doesen't auto mount so sofar f13 is worse than f12 :(
Comment 1 Andre Robatino 2010-06-05 12:05:39 EDT
You probably have to set NM_CONTROLLED to "no" (you can also do this in the s-c-n GUI by unchecking "Controlled by NetworkManager").
Comment 2 Riku Seppala 2010-06-05 12:35:54 EDT
Ah, yes now I can activate wlan. But it just doesn't work.

Error org.freedesktop.NetworkManagerSettings.InvalidConnection: ifcfg file '/etc/sysconfig/network-scripts/ifcfg-wlan0' unknown
Error org.freedesktop.NetworkManagerSettings.InvalidConnection: ifcfg file '/etc/sysconfig/network-scripts/ifcfg-wlan0' unknown
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0... failed; no link present.  Check cable?


Funny that it asks to check cable for wireless connection ;)
Comment 3 Riku Seppala 2010-06-15 10:30:34 EDT
Basically my problem now is I can't connect to wlan with hidden SSID.
Comment 4 Dan Williams 2010-06-15 12:24:31 EDT
Can you grab the output of 'lsmod' to see what kernel driver your device uses?  Hidden SSIDs are somewhat tricky since they can't be autodetected easily.
Comment 5 Riku Seppala 2010-06-15 13:36:59 EDT
Created attachment 424246 [details]
output of lsmod

Driver is ath5k.

I couldn't connect with my laptop either, it uses b43.


Though I just bought new ADSL modem right before I installed F13. F12 could connect to hidden SSID but that was with different ADSL modem. The old one acted weird so I needed new.

Now that I think of it, this new one must be working somehow differently. At least Windows Vista could connect to even with hidden SSID.

This is D-Link DSL 2640B Wireless G ADSL2+ modem router. 
http://www.dlink.com/products/?pid=567
Comment 6 Dan Williams 2010-06-28 16:30:07 EDT

*** This bug has been marked as a duplicate of bug 516788 ***

Note You need to log in before you can comment on or make changes to this bug.