Bug 600670 - genkey segfaults
Summary: genkey segfaults
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Newt   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: Radek Bíba
URL:
Whiteboard:
Keywords: Regression
Depends On: 598160
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-05 14:42 UTC by Joe Orton
Modified: 2010-11-10 22:13 UTC (History)
3 users (show)

Fixed In Version: perl-Newt-1.08-26.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 598160
Environment:
Last Closed: 2010-11-10 22:13:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simpler script that segfaults (5.05 KB, text/plain)
2010-06-11 17:57 UTC, Elio Maldonado Batiz
no flags Details

Description Joe Orton 2010-06-05 14:42:16 UTC
+++ This bug was initially created as a clone of Bug #598160 +++

Description of problem:
I received an email with the following:


  Certificate for hostname 'iridium', in file (or by nickname):
     /etc/pki/tls/certs/localhost.crt

  The certificate needs to be renewed; this can be done
  using the 'genkey' program.

When attempting to run genkey --days 365 localhost (this is a workstation using a self signed key) I get an error about a /etc/pki/tls/private/localhost.key existing, to remove it first and then re-run genkey. Once removed if I re-run genkey I get an immediate segfault. I just ran this on a CentOS 5.4 box moments before without a problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. genkey --days 365 servername
2.
3.
  
Actual results:
segfault

Expected results:
New cert

Additional info:

--- Additional comment from nathanael@gnat.ca on 2010-06-01 11:19:52 EDT ---

Also, genkey --gdb servername is of no help as it just segfaults anyway before getting into gdb

Comment 2 RHEL Product and Program Management 2010-06-05 15:02:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Elio Maldonado Batiz 2010-06-06 19:59:16 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=598160#c3

Comment 4 Elio Maldonado Batiz 2010-06-11 17:57:32 UTC
Created attachment 423352 [details]
simpler script that segfaults

This is not a bug on genkey.  This script is basically a HelloWorld that uses perl_Newt and when I run it, 'perl ./hello.pl elio', it segfaults on F-13 and not on F-12. I looked at perl_newt in F-12 &F-13 and the code is identical expect that it was rebuilt with a slighly newer version of perl in F-13.

Comment 5 Elio Maldonado Batiz 2010-06-11 18:00:04 UTC
My perl skills are a bit limited and knowledge of perl_newt more so.
Joe, do you see anything wrong with hello.pl?

Comment 6 Joe Orton 2010-06-16 13:52:31 UTC
Ah, sorry for blaming you for this unnecessarily, my bad :(

Yes this is clearly a perl-Newt issue.

Comment 11 releng-rhel@redhat.com 2010-11-10 22:13:37 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.