Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 600832 - RFE/PATCH: add auto-color aliases for grep like we have for ls
RFE/PATCH: add auto-color aliases for grep like we have for ls
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grep (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-06 05:10 EDT by Ville Skyttä
Modified: 2011-05-22 11:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: grep-2.6.3-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 11:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add auto-color shell aliases (2.22 KB, patch)
2010-06-06 05:10 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2010-06-06 05:10:08 EDT
Created attachment 421562 [details]
Add auto-color shell aliases

Here's a patch that adds auto-color shell aliases for grep like we've had for ages for ls.

While at it, fixes one unescaped macro in %changelog.
Comment 1 Jaroslav Škarvada 2010-06-07 05:58:39 EDT
Thanks, looks good, I will integrate it.
Comment 2 Jaroslav Škarvada 2010-06-07 11:33:14 EDT
Fixed in grep-2.6.3-3.fc14.
Comment 3 Cristian Ciupitu 2011-05-21 21:08:43 EDT
What about egrep and fgrep?
Comment 4 Jaroslav Škarvada 2011-05-22 10:44:21 EDT
(In reply to comment #3)
> What about egrep and fgrep?

See bug 697895, it was pushed as f14 update:
http://admin.fedoraproject.org/updates/grep-2.8-1.fc14
Please test it and give it some karma.
Comment 5 Cristian Ciupitu 2011-05-22 11:10:23 EDT
Thanks! I didn't find that bug report because I thought people would use the American spelling, not the British one. Next time I'll listen to my instincts.

Note You need to log in before you can comment on or make changes to this bug.