Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 600860 - Word missing from en-US dictionary: "decryption"
Word missing from en-US dictionary: "decryption"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hunspell-en (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-06 07:36 EDT by Mat Booth
Modified: 2010-06-21 08:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: hunspell-en-0.20100322-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-06 16:05:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mat Booth 2010-06-06 07:36:06 EDT
'Decryption' is a valid noun form of the English verb 'decrypt.' It is present in the British dictionary, but it seems to be missing from the US dictionary, see below:



[mbooth@sd ~]$ echo decryption | hunspell -d en_GB
Hunspell 1.2.8
*

[mbooth@sd ~]$ echo decryption | hunspell -d en_US
Hunspell 1.2.8
& decryption 4 0: encryption, deception, description, decoration
Comment 1 Caolan McNamara 2010-06-06 16:05:12 EDT
Indeed, seems inconsistent. Filed an upstream bug for this as...

https://sourceforge.net/tracker/?func=detail&aid=3012183&group_id=10079&atid=1014602

the "decrypt" words are there in the source package, but are considered more "exotic" level 70 words than the "encrypt" family which appear <= level 60 which is the default spell-checking level. I can easily bump this to level 70 to get them in, which I've done for the next release, but ideally decrypt/encrypt would both be of equal level.

hunspell-en-0_20100322-3_fc14
Comment 2 Fedora Update System 2010-06-10 10:18:11 EDT
hunspell-en-0.20100322-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/hunspell-en-0.20100322-1.fc13
Comment 3 Fedora Update System 2010-06-10 10:32:17 EDT
hunspell-en-0.20100322-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/hunspell-en-0.20100322-1.fc12
Comment 4 Fedora Update System 2010-06-21 08:56:00 EDT
hunspell-en-0.20100322-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-06-21 08:57:44 EDT
hunspell-en-0.20100322-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.