Bug 600939 - Yum times out when contacting servers.
Summary: Yum times out when contacting servers.
Keywords:
Status: CLOSED DUPLICATE of bug 600937
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-06 18:40 UTC by fedora-bugzilla
Modified: 2014-01-21 23:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-18 18:52:17 UTC


Attachments (Terms of Use)

Description fedora-bugzilla 2010-06-06 18:40:12 UTC
Description of problem: 
Since doing a yum update a few days ago i can no longer use yum to update/install software.


Version-Release number of selected component (if applicable):
3.2.27


How reproducible:
Fully update system


Steps to Reproduce:
1. update system
2. try running yum update
3. wait for time outs
  
Actual results: 
yum times out when contacting any websites


Expected results: 
Yum to work like it used to.

Additional info:

I suspected this was related to a recent curl/libcurl update so i originally posted to this bug report. https://bugzilla.redhat.com/process_bug.cgi 

Basicly the updated curl was causing yum to timeout when trying to contract mirror servers for update/package info. Upgrading to the "testing" curl posted there did NOT fix the issue...but downgrading the curl version to a older version DID work...but each time i use yum now it wants to update curl... so today i updated everything and yum is broken again. So as of right now i can not maintain packages through yum.

The error i get when using yum is:
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

If i manually try to goto the link( https://mirrors.fedoraproject.org/metalink?repo=fedora-13&arch=x86_64 ) i can and it prompts me to download the xml file with the list of mirrors in it. I can also use wget to download the xml file fine....but if i goto use urlgrabber with the same url..it times out.

Im using ipv4 and ipv6(via hurricane electric)

On that other bug report someone suggested i include a few files....it seems i can only attache one file with this original post so im gonna attach the nsswitch.conf file and just put the resolve.conf in here since its short.

/etc/resolv.conf:
# Generated by NetworkManager
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4

I dont have a /etc/gai.conf

Comment 1 Carl G. 2010-06-18 18:52:17 UTC

*** This bug has been marked as a duplicate of bug 600937 ***


Note You need to log in before you can comment on or make changes to this bug.