Bug 60095 - PS/2->USB converter doesn't work
PS/2->USB converter doesn't work
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 17:36 EST by Bill Nottingham
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 19:54:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2002-02-19 17:36:47 EST
Using 2.4.9-21 & 2.4.9-28.

I have an ATEN UC100KM PS/2->USB converter (plug in PS/2 mouse & keyboard, and
then  plug the converter into the USB port.) It doesn't appear to work at all
under Linux.

It works under Windows XP, and in the BIOS (both on ia64 and x86); it does not
work in LILO or grub on the x86 box I tried it on.

I have tried both the HID keyboard and mouse drivers, and rebuilding the kernel
with usbkbd and usbmouse enabled; nothing seems to work. If I look at
/proc/interrupts, the USB controller only registers interrupts on device
plug/unplug; there appeear to be no interrupts generated when I press keys or
move the mouse.
Comment 1 Pete Zaitcev 2002-02-19 18:44:33 EST
Bill, check the patch linux-2.4.17-usb-55878.patch in kernel HEAD.
It may help, but on the other hand, usbkbd worked with that device
(when loaded in controlled environment,
echo /bin/true > /proc/sys/kernel/hotplug)

I did not put it into pensacola or enigma-s390-erratum,
do you want it in there? Please test and let me know how
it goes.

Also, if the patch does not fix the problem, attach your
dmesg and /proc/bus/usb/devices.
Comment 2 Bill Nottingham 2002-02-19 19:54:22 EST
That patch worked for me ok. Cool, now we can get more machines in the rack
attached to the KVM.

I don't know that this *needs* to be an errata patch, but it would be nice if it
doesn't break other things. (famous last words)
Comment 3 Pete Zaitcev 2002-02-19 20:39:16 EST
I copied it into errata, so whatever goes after -21
should have it.

Note You need to log in before you can comment on or make changes to this bug.