Bug 60096 - colorls doesn't work for Xsession
colorls doesn't work for Xsession
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 17:41 EST by Birger Langkjer
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 17:40:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Birger Langkjer 2002-02-19 17:41:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
When I choose Xsession (Window Maker) in gdm, when I start an xterm from the
startmenu or the dock, there are no colors with 'ls'. There is if I start an
xterm from another xterm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start Window Maker from Xsession (gdm)
2.Doubleclick the xterm icon in the dock
3.
	

Actual Results:  no colors with 'ls'

Expected Results:  there should have been colors according to filetype

Additional info:
Comment 1 Alexei Podtelezhnikov 2002-02-19 19:42:31 EST
Are you using bash or tcsh? I have exactly the same problem with tcsh, but everything works with bash.
I even know why. Colorls alias is set in /etc/csh.login which never gets executed in a non-ligin shell 
e.g. under Xsession. Using bash works fine /etc/bashrc gets always loaded no matter in login or 
non-login shell.

There are similar bugs to this one reported.
Comment 2 Birger Langkjer 2002-02-20 12:09:03 EST
I assume it is BASH, I just use the standard on Redhat. There is an executable 
file i /etc/profile.d/ called colorls.sh - I thought this was the config-file?
Comment 3 Alexei Podtelezhnikov 2002-02-20 16:26:24 EST
Both /etc/bashrc and /etc/csh.login load stuff from /etc/profile.d 
including colorls. 
Three things to check: 1) run "bash" to make sure you really using bash. 
Otherwise, check the end of the line in /etc/passwd corresponding to the user 
in question. 2) run "ls --color" that should be colorful no matter what. 
3) maybe, Window Maker terminal is supposed to be black-n-white?
Comment 4 Havoc Pennington 2002-02-21 00:33:13 EST
This is probably either a tcsh, WindowMaker, or xinitrc bug rather than a gdm bug.
However I'm not sure which of those to pass the buck too. ;-) Leaving bug NEW
for now.
Comment 5 Havoc Pennington 2002-02-24 11:03:55 EST
Now that I re-read the report, this must be WindowMaker stripping the
environment or something like that, because it works if you start the xterm from
another xterm.
Comment 6 Birger Langkjer 2002-02-26 15:24:44 EST
I use Bash. There is a problem with Window Maker and icewm, but not lwm and twm.
If I put:

xterm &
exec wmaker

in .xsession script, the first xterm has colors, but not the ones I start by
clicking the button. If I use ls --colors xterm has blue and green but no red.
Comment 7 Phil Copeland 2002-08-12 14:53:53 EDT
Try with the latest rawhide version

ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS

Phil
=--=
Comment 8 Alexei Podtelezhnikov 2002-10-07 03:04:47 EDT
Please read bug 59446. The discussed problem explained my colorls problem 
in tcsh in Xterm (bug 54309). 

Does WindowMaker use /etc/csh.login or /etc/csh.cshrc?

How difficult it is to release errata for setup? 
Oh well, I tried... It looks pretty bad: setup's files get modified a lot
after their initial installation, so I only got rpmnew's all over the /etc/.
Comment 9 Havoc Pennington 2004-11-09 17:40:05 EST
Closing bug, since we don't even ship windowmaker anymore.

Note You need to log in before you can comment on or make changes to this bug.