Bug 60100 - kpackage backtrace: double click on empty folder == crash
kpackage backtrace: double click on empty folder == crash
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdeadmin (Show other bugs)
7.2
i386 Linux
high Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-19 20:05 EST by Ben Levenson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 02:29:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2002-02-19 20:05:00 EST
Description of Problem:
  kpackage will crash if you try to expand an empty folder. it only
  happens the second time it is clicked (though, I probably should've
  gotten the clue the first time I clicked on it ;o) ).

Version-Release number of selected component (if applicable):
kdeadmin-2.2.2-2

How Reproducible:
100%

Steps to Reproduce:
1. find an empty folder to click on (possibly under the <NEW> or <UPDATED>
   tab)
2. click on <+-RPM> folder --> nothing happens (expected behavior)
3. click on it again --> crash

Actual Results:
kpackage crashes with the following backtrace:

(no debugging symbols found)...(no debugging symbols found)...
0x40f55ca9 in __wait4 () from /lib/i686/libc.so.6
#0  0x40f55ca9 in __wait4 () from /lib/i686/libc.so.6
#1  0x40fd16b4 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x405a31e8 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.3
#3  <signal handler called>
#4  0x408e9605 in QListViewItem::itemBelow ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#5  0x408ee61a in QListView::setOpen () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#6  0x408e99ae in QListView::contentsMousePressEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#7  0x4035afb8 in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.3
#8  0x08084c6a in procbuf::~procbuf ()
#9  0x4092ac31 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#10 0x4092a461 in QScrollView::eventFilter ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#11 0x408e94d4 in QListView::eventFilter ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#12 0x4084dcab in QObject::activate_filters ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#13 0x40896dbe in QWidget::event () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#14 0x407ff891 in QApplication::notify () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#15 0x40509e79 in KApplication::notify () from /usr/lib/libkdecore.so.3
#16 0x407cdd5f in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#17 0x407cb248 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#18 0x407ca21a in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#19 0x4080174c in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#20 0x407ca197 in QApplication::exec () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#21 0x08075b5d in KDialog::marginHint ()
#22 0x40eb7627 in __libc_start_main (
    main=0x80756d0 <KDialog::marginHint(void)+109352>, argc=7,
    ubp_av=0xbffed9a4, init=0x8057140 <_init>, fini=0x80a7c20 <_fini>,
    rtld_fini=0x4000dcc4 <_dl_fini>, stack_end=0xbffed99c)
    at ../sysdeps/generic/libc-start.c:129
Comment 1 Alexei Podtelezhnikov 2002-02-20 02:29:02 EST
I've seen this too. Did you report it to bugs.kde.org? That's where they might 
fix it.
Comment 2 Bernhard Rosenkraenzer 2002-03-21 04:17:00 EST
Can't reproduce it in 3.0
Comment 3 David Lawrence 2002-05-28 00:27:48 EDT
changed to proper priority. Seems like html form data corruption occured somehow.

Note You need to log in before you can comment on or make changes to this bug.