Bug 601030 - virt-v2v | fail to convert the ESX guest with SCSI device passthru
Summary: virt-v2v | fail to convert the ESX guest with SCSI device passthru
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
(Show other bugs)
Version: 5.7
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 03:23 UTC by Mohua Li
Modified: 2013-04-30 23:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 11:45:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
esx configuration file for test_v2v guest (3.37 KB, text/plain)
2010-06-07 04:06 UTC, Mohua Li
no flags Details

Description Mohua Li 2010-06-07 03:23:05 UTC
Description of problem:
convert the ESX guest with SCSI device passthru,

[root@dhcp-66-70-148 v2v]# virt-v2v -f /etc/virt-v2v.conf  -ic esx://10.66.65.108/?no_verify=1  -o rhev -osd  10.66.90.115:/vol/v2vrwu/rwuv2v/  test_v2v
libvirt error code: 1, message: internal error Invalid or not yet handled value '/vmfs/devices/genscsi/mpx.vmhba32:C0:T0:L0' for VMX entry 'scsi0:2.fileName'


Here is the configuration about SCSI device of the guest

/vmfs/volumes/4bc2a849-50805e00-0f2c-0023ae9d846f/test_v2v # cat test_v2v.vmx | grep -i SCSI

sched.scsi0:0.shares = "normal"

scsi0.present = "TRUE"

scsi0:0.present = "TRUE"

scsi0.sharedBus = "none"

scsi0.virtualDev = "lsilogic"

scsi0:0.fileName = "rhel5u4-local.vmdk"

scsi0:0.deviceType = "scsi-hardDisk"

scsi0:0.redo = ""

scsi0.pciSlotNumber = "16"

scsi0:1.present = "TRUE"

scsi0:1.fileName = "test_v2v.vmdk"

scsi0:1.deviceType = "scsi-hardDisk"

scsi0:1.redo = ""

scsi0:2.present = "TRUE"

scsi0:2.deviceType = "scsi-passthru"

scsi0:2.fileName = "/vmfs/devices/genscsi/mpx.vmhba32:C0:T0:L0"

scsi0:2.allowGuestConnectionControl = "FALSE"

scsi0:3.present = "TRUE"

scsi0:3.fileName = "test_v2v_1.vmdk"

scsi0:3.deviceType = "scsi-hardDisk"




Version-Release number of selected component (if applicable):
virt-v2v-0.6.0.3

How reproducible:
always

Steps to Reproduce:
1,virt-v2v -f /etc/virt-v2v.conf  -ic esx://10.66.65.108/?no_verify=1  -o rhev -osd  10.66.90.115:/vol/v2vrwu/rwuv2v/  test_v2v
  
Actual results:
report error and exit

Expected results:
continue and give warning "the passthru device maybe not be available" 

Additional info:

Comment 1 Mohua Li 2010-06-07 04:06:33 UTC
Created attachment 421711 [details]
esx configuration file for test_v2v guest

Comment 2 RHEL Product and Program Management 2010-09-05 07:57:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2011-02-01 11:45:12 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.