Bug 60105 - Installer hanging on PC with 440GX chipset and Adaptec 2400A Controller
Installer hanging on PC with 440GX chipset and Adaptec 2400A Controller
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 01:23 EST by Brian Ipsen
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-21 02:32:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ipsen 2002-02-20 01:23:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
When trying to install RH 7.2 on a PC with 440GX chipsen (Intel L440GXB4+ 
server board) and an Adaptec ATA 2400A IDE RAID controller, the installer locks 
the PC right after writing "booting the kernel." to the monitor.
 Starting the installation with:
linux apic
as normally required with this kind of chipset/board does not solve the problem.
The installation has been tried from a "normal" RH 7.2 CD, and from and updated 
set with Kernel 2.4.9-21 - both freezes completely when trying to boot the 
kernel.
Removing the ATA 2400A card makes the installation run without problems when 
starting with "linux apic".


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Power PC on
2. Boot from RH 7.2 CD
3. Type linux apic at boot prompt
4. press enter.
	

Actual Results:  PC froze/locked up

Expected Results:  Installation should have started.

Additional info:
Comment 1 Arjan van de Ven 2002-02-20 11:16:18 EST
---------------------
Most implementations using the 440GX chipset require the "apic"
option to function correctly.  When this is the case, providing
DMI information to Red Hat as documented below[1] may allow us to
automate that setting in the future.

On some systems, the "apic" boot flag may not work.  Unfortunately,
because of Intel Proprietary information, these platforms are not
supported at this time.


-----------------------

(Official Intel approved statement about 440GX vs linux)

You can try moving the card to other slots, maybe that helps.

Comment 2 Brian Ipsen 2002-02-20 19:12:49 EST
Moving the card to another slot solved the problem. The question is than what 
made the system lock up so quick - in such a way that the question for a driver 
disk wasn't presented.
Since the question for the driver wasn't presented it must be assumed, that the 
problem relies somewhere between the 440GX chipset and the kernel.
Comment 3 Arjan van de Ven 2002-02-21 02:32:52 EST
Oh absolutely, or rather "chipset+bios" and the kernel.
There's bugs in the bios we informed Intel about but Intel refuses to fix them,
and they are refusing to help fix other issues re 440GX :(

Note You need to log in before you can comment on or make changes to this bug.