Bug 601056 - LiveCD-KDE does not contain plugins for knetworkmanager
Summary: LiveCD-KDE does not contain plugins for knetworkmanager
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD - KDE   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sebastian Vahl
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 06:31 UTC by Vasiliy Glazov
Modified: 2010-11-30 14:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 14:40:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vasiliy Glazov 2010-06-07 06:31:14 UTC
Description of problem:

LiveCD-KDE not contain plugins for knetworkmanager
knetworkmanager-openvpn                         
knetworkmanager-pptp                           
knetworkmanager-vpnc

It's very bad because people can't connect to internet in live-cd mode and after install to hard drive.

Version-Release number of selected component (if applicable):

F13

Comment 1 Sebastian Vahl 2010-11-29 19:21:15 UTC
Sorry for not replying for such a long time. I must have missed this bug in my mails entirely :(

I`ve set this question on top of tomorrow's kde-sig-meeting agenda: https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-11-30


@Rex, Kevin: I will not be able to attend to tommorrow's meeting. I've done a test spin with these packages and the increased size is quite minimal - only 1M. The package diff is:

> NetworkManager-openvpn
> NetworkManager-pptp
> NetworkManager-vpnc
> openvpn
> pkcs11-helper
> pptp
> vpnc
> vpnc-script

Comment 2 Kevin Kofler 2010-11-29 19:28:06 UTC
Oh right, the problem of the VPN plugins. They're split out not to drag in all the VPN stuff, but apparently that's rather counterproductive if they're really so small. Maybe we should just merge them into the main package as some people suggested? Or at least drag them onto the live CD by default. We can take that up in the meeting.

Unfortunately, the earliest release we can fix this in (in official ISOs) is Fedora 15, because Fedora does not do official respins of releases. So we cannot fix this for Fedora 13 or 14.

Comment 3 Vasiliy Glazov 2010-11-29 21:13:21 UTC
OK, at least it will be in F15 release.

Comment 4 nucleo 2010-11-30 14:04:17 UTC
Plugins renamed to
kde-plasma-networkmanagement-openvpn
kde-plasma-networkmanagement-pptp
kde-plasma-networkmanagement-vpnc

They are added as optional to kde-desktop in comps-f15.

Comment 5 Kevin Kofler 2010-11-30 14:40:15 UTC
As discussed and agreed on in today's KDE SIG Meeting, I changed them from optional to default:

http://git.fedorahosted.org/git/?p=comps.git;a=commit;h=de392ced777bb3e14c975a36d8533083a8719f0f
Make kde-plasma-networkmanagement-openvpn, kde-plasma-networkmanagement-pptp and kde-plasma-networkmanagement-vpnc default for kde-desktop in comps-f15 (#601056).


Note You need to log in before you can comment on or make changes to this bug.