Bug 60110 - Unsolvable dependency generates messy traceback
Unsolvable dependency generates messy traceback
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-20 05:28 EST by Chip Turner
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 13:25:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Turner 2002-02-20 05:28:35 EST
While playing with the rhn satellite channel, I found myself getting this
traceback a few times.  It looks like it pops up when a dependency can't be
solved.  This is running up2date-2.7.27-7.x.2.

Traceback (innermost last):
  File "/usr/sbin/up2date", line 1111, in ?
    main()
  File "/usr/sbin/up2date", line 370, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 1002, in batchRun
    (depPackages, conflicts) = up2date.dryRun(selPkgList, printCallback,
percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 2020, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/up2date.py", line 1986, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1952, in process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1839, in __dependencies
    for s in solved[:]:
TypeError: unsliceable object
Comment 1 Adrian Likins 2002-02-20 13:25:46 EST
should be fix in cvs (2.7.29)

Note You need to log in before you can comment on or make changes to this bug.