Bug 601110 - X server caught segfault and aborted after unlocking screen
Summary: X server caught segfault and aborted after unlocking screen
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d0ad2eef6831b86d7534c4c4c6c...
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 09:06 UTC by James Ettle
Modified: 2018-04-11 08:45 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-drv-intel-2.12.0-1.fc13.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-18 10:02:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.65 KB, text/plain)
2010-06-07 09:06 UTC, James Ettle
no flags Details
Xorg.0.log from failed session (68.57 KB, text/plain)
2010-06-07 09:09 UTC, James Ettle
no flags Details

Description James Ettle 2010-06-07 09:06:29 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/Xorg :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-s64a0k/database -nolisten tcp vt1
comment: Aborted after unlocking screensaver. Screen had blanked.
component: xorg-x11-server
crash_function: raise
executable: /usr/bin/Xorg
global_uuid: d0ad2eef6831b86d7534c4c4c6c979fb02180c91
kernel: 2.6.33.5-rhapsody.fc13.noecd.fcbfix-181
package: xorg-x11-server-Xorg-1.8.0-12.fc13
rating: 4
reason: Process /usr/bin/Xorg was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

Comment 1 James Ettle 2010-06-07 09:06:31 UTC
Created attachment 421755 [details]
File: backtrace

Comment 2 James Ettle 2010-06-07 09:09:49 UTC
Created attachment 421757 [details]
Xorg.0.log from failed session

Comment 3 Matěj Cepl 2010-06-11 12:52:55 UTC
#7  0x0000000000547a18 in miDoCopy (pSrcDrawable=0x401f0f0, 
    pDstDrawable=0x4260870, pGC=0x3b64d10, xIn=0, yIn=0, widthSrc=1280, 
    heightSrc=800, xOut=0, yOut=0, copyProc=0x7f45c68510a0 <uxa_copy_n_to_n>, 
    bitPlane=0, closure=0x0) at micopy.c:192
        prgnSrcClip = 0x0
        freeSrcClip = 0
        prgnExposed = 0x0
        rgnDst = {extents = {x1 = 0, y1 = 0, x2 = 0, y2 = 0}, data = 0x0}
        dx = <value optimized out>
        dy = <value optimized out>
        box_x1 = <value optimized out>
        box_y1 = <value optimized out>
        box_x2 = <value optimized out>
        box_y2 = <value optimized out>
        fastSrc = 0
        fastDst = 0
        fastExpose = 0
#8  0x00007f45c6851020 in uxa_copy_area (pSrcDrawable=0x401f0f0, 
    pDstDrawable=0x4260870, pGC=0x3b64d10, srcx=0, 
    srcy=<value optimized out>, width=<value optimized out>, height=800, 
    dstx=0, dsty=0) at uxa-accel.c:506
        uxa_screen = <value optimized out>
#9  0x00000000004d4478 in damageCopyArea (pSrc=0x401f0f0, pDst=0x4260870, 
    pGC=0x3b64d10, srcx=0, srcy=0, width=1280, height=800, dstx=0, dsty=0)
    at damage.c:949
        ret = <value optimized out>
        pGCPriv = 0x3b64ed0
        oldFuncs = 0x7cd2e0
#10 0x00007f45c684cc02 in I830DRI2CopyRegion (drawable=0x4260870, 
    pRegion=<value optimized out>, destBuffer=<value optimized out>, 
    sourceBuffer=<value optimized out>) at i830_dri.c:367
        srcPrivate = <value optimized out>
        dstPrivate = <value optimized out>
        screen = <value optimized out>
        scrn = 0x244cb20
        intel = 0x244d940
        src = 0x401f0f0
        dst = 0x4260870
        pCopyClip = 0x0
        gc = 0x3b64d10
        __FUNCTION__ = "I830DRI2CopyRegion"
        __PRETTY_FUNCTION__ = "I830DRI2CopyRegion"
#11 0x00007f45c684d8b9 in I830DRI2FrameEventHandler (frame=58472, 
    tv_sec=1275883522, tv_usec=833588, event_data=0x45c36a0) at i830_dri.c:558
        region = {extents = {x1 = 0, y1 = 0, x2 = 1280, y2 = 800}, data = 0x0}
        swap_type = <value optimized out>
        event = 0x45c36a0
        drawable = 0x4260870
        screen = <value optimized out>
        scrn = <value optimized out>
        intel = <value optimized out>
        status = <value optimized out>
        __func__ = "I830DRI2FrameEventHandler"
#12 0x000000385ae067c3 in drmHandleEvent (fd=8, evctx=0x244d3a8)
    at xf86drmMode.c:787
        buffer = "\001\000\000\000 \000\000\000\240\066\\\004\000\000\000\000\002p\fL4\270\f\000h\344\000\000\000\000\000\000\001\000\000\000 \000\000\000 Z\237\004\000\000\000\000\002p\fL4\270\f\000h\344\000\000\000\000\000\000\000\372\327\003\000\000\000\000@S\vO\377\177\000\000\000S\vO\377\177\000\000~f\274#\343z\274\245 V\vO\377\177\000\000\000\372\327\003\000\000\000\000\300\231\206\004\000\000\000\000~f\274#\343z\274\245\000\000\000\000\000\000\000\000 Y\vO\377\177\000\000\300\231\206\004\000\000\000\000\316\257C", '\000' <repeats 13 times>"\211, \267C\000\000\000\000\000\350\256\227\023\001\000\000\000\000\000\000\000\022\000\000\000(\000\000\022\001", '\000' <repeats 11 times>, "0\200{\000\377\177\000\000\000\001\000\000\000\000\000\000\260\244\017\004\000\000\000\000\320\357\353\003\000\000\000\000\000\372\327\003\000\000\000\000"...
        len = 64
        i = <value optimized out>
        e = 0x7fff4f0b52a0
        vblank = 0x7fff4f0b52a0
#13 0x000000000043159b in WakeupHandler (result=3, pReadmask=0x7e2b00)
    at dixutils.c:403
        i = 0
        j = <value optimized out>
#14 0x000000000045a767 in WaitForSomething (pClientsReady=0x3d495c0)
    at WaitFor.c:232
        i = <value optimized out>
        waittime = {tv_sec = 0, tv_usec = 332971}
        wt = 0x7fff4f0b5950
        timeout = <value optimized out>
        clientsReadable = {fds_bits = {0 <repeats 16 times>}}
        clientsWritable = {fds_bits = {62185992, 139937673361597, 62275456, 
            66765584, 69603056, 69601392, 3, 73006768, 38078704, 69601392, 3, 
            71613648, 73000896, 8267520, 8267528, 0}}
        selecterr = 104
        nready = <value optimized out>
        devicesReadable = {fds_bits = {0, 75870016, 75870016, 62118576, 
            73359704, 0, 38080208, 139937651353346, 73328048, 
            139937659990834, 38080208, 5066748, 10, 62192464, 0, 73328048}}
        now = <value optimized out>
        someReady = <value optimized out>
#15 0x000000000042c042 in Dispatch () at dispatch.c:375
        clientReady = 0x3d495c0
        result = <value optimized out>
        client = <value optimized out>
        nready = <value optimized out>
        icheck = 0x7e1890
        start_tick = <value optimized out>
#16 0x00000000004219ca in main (argc=<value optimized out>, 
    argv=0x7fff4f0b5b88, envp=<value optimized out>) at main.c:286
        i = <value optimized out>
        alwaysCheckForInput = {0, 1}

Comment 4 James Ettle 2010-07-20 09:29:28 UTC
Hmm... I've not seen anything since trying xorg-x11-drv-intel-2.12.0-1.fc13.x86_64, but I don't think I've been testing it long enough.

Comment 5 Matěj Cepl 2010-07-20 21:36:38 UTC
OK, let's keep that needinfo here for some time more.

Comment 6 James Ettle 2010-08-02 22:15:18 UTC
I've not had any X crashes since my last comment, so personally I regard this (and my other x-x-d-i bugs) as fixed... has Intel driver 2.12 been pushed to updates-testing?

Comment 7 James Ettle 2010-08-12 07:32:41 UTC
10 days later, I've still not seen any crashes (or any bad behaviour for that matter) with Intel driver 2.12.


Note You need to log in before you can comment on or make changes to this bug.