Bug 60112 - procmail fails to create mail spools when invoked by postfix
Summary: procmail fails to create mail spools when invoked by postfix
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procmail   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 60073
TreeView+ depends on / blocked
 
Reported: 2002-02-20 12:04 UTC by Bernhard Rosenkraenzer
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 12:05:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2002-02-20 12:04:31 UTC
Description of Problem: 
When used as delivery agent for postfix, mail spools for new users aren't created. 
Since postfix doesn't run as root, procmail can't create /var/spool/mail/username if 
invoked by postfix rather than sendmail. 
 
Version-Release number of selected component (if applicable): 
3.22-2 
 
Suggested fix: 
Make procmail setgid and drop privileges right after creating the mail spool and setting 
sane permissions on it.

Comment 1 Trond Eivind Glomsrxd 2002-02-20 16:04:00 UTC
procmail is not getting a suid bit - it's not that trustworthy.


Note You need to log in before you can comment on or make changes to this bug.