Bug 601158 - PackageKit - TypeError: Can not create packages table: database is locked
Summary: PackageKit - TypeError: Can not create packages table: database is locked
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-metadata-parser   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Jiri Kastner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-07 11:20 UTC by Jiri Kastner
Modified: 2010-07-16 18:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 18:48:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jiri Kastner 2010-06-07 11:20:56 UTC
Description of problem:
on rhel6 machine i noticed traceback (see bellow) regarding locked database

Version-Release number of selected component (if applicable):
PackageKit-0.5.8-6.el6.x86_64

How reproducible:


Steps to Reproduce:
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2437, in get_updates
    ygl = self.yumbase.doPackageLists(pkgnarrow='updates')
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1914, in doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 793, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 621, in _getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 774, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 564, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 279, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 187, in populate
    dobj = repo_cache_function(xml, csum)
  File "/usr/lib64/python2.6/site-packages/sqlitecachec.py", line 46, in getPrimary
    self.repoid))
TypeError: Can not create packages table: database is locked


Expected results:


Additional info:

Comment 2 Richard Hughes 2010-06-07 13:27:34 UTC
I'm pretty sure this is a bug caused by the huge number of not widely used yum plugins installed. I can't reproduce on the vnc instance you've got open, but if you can work out what plugin is causing this failure we can blacklist it in PackageKit. I'm pretty sure it's a problem in yum-metadata-parser, so I'll reassign to yum for feedback and any ideas.

Comment 3 James Antill 2010-06-07 13:45:43 UTC
The only other time I've seen something like this was when /var/cache was on NFS, and rpc.lockd wasn't working ... thus. sqlite couldn't lock the .sqlite file (which it does on creation).

The vnc session seems dead (I can connect, but not type anything) so I can't check if that matches what the machine looks like.

Comment 7 James Antill 2010-07-16 18:48:16 UTC
Given it can't be reproduced, and AFAIK it's unlikely to be a yum/y-m-p bug anyway ... going to close this out.


Note You need to log in before you can comment on or make changes to this bug.