Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 601212 - Python 2.4 + hashlib causes AttributeError calling hmac.new()
Python 2.4 + hashlib causes AttributeError calling hmac.new()
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: Django (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Milner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 09:34 EDT by Daniel Mach
Modified: 2010-06-09 15:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 15:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2010-06-07 09:34:29 EDT
Django 1.2 running on python2.4 & python-hashlib on el5 requires following patch:
http://code.djangoproject.com/changeset/13310?format=diff&new=13310
http://code.djangoproject.com/ticket/13653

I've applied the patch and verified it really works.
Comment 1 Steve Milner 2010-06-07 09:58:27 EDT
Thanks for the patch. I'll verify it works fine on F12+ as well before applying it.
Comment 2 Steve Milner 2010-06-08 13:58:59 EDT
I've applied it and built it locally and it seems to work on Fedora fine. I tried doing a raw hide build but there is some dep issues at the moment (unrelated to the package itself). Once that gets fixed I'll send it back through and make sure it builds.
Comment 3 Steve Milner 2010-06-09 15:11:37 EDT
I've included the patch but 1.2.x will not be released for EPEL-5. I've been reminded that since this release breaks some backwards compatibility it is considered a major release. If you are in need of 1.2.x on EPEL-5 you can rebuild a Fedora package, but be warned that this will break current EPEL-5 Django applications (such as ReviewBoard). I'll leave the patch in for those who do have a need to rebuild.

Ref: https://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#A_major_version_update

Thanks again for the bug report!

Note You need to log in before you can comment on or make changes to this bug.