Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601215 - [abrt] seahorse-plugins-2.30.1-1.fc14: handle_clipboard_owner_change: Process /usr/lib64/seahorse/seahorse-applet was killed by signal 11 (SIGSEGV)
[abrt] seahorse-plugins-2.30.1-1.fc14: handle_clipboard_owner_change: Process...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: seahorse-plugins (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:b090600ad8646e5c1a7d87aaa4c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 09:42 EDT by Tom London
Modified: 2011-01-25 16:00 EST (History)
2 users (show)

See Also:
Fixed In Version: seahorse-plugins-2.30.1-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 00:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.89 KB, text/plain)
2010-06-07 09:42 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2010-06-07 09:42:38 EDT
abrt version: 1.1.4
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/seahorse/seahorse-applet --oaf-activate-iid=OAFIID:GNOME_SeahorseApplet_Factory --oaf-ior-fd=24
component: seahorse-plugins
crash_function: handle_clipboard_owner_change
executable: /usr/lib64/seahorse/seahorse-applet
global_uuid: b090600ad8646e5c1a7d87aaa4cedec31fb096eb
kernel: 2.6.34-20.fc14.x86_64
package: seahorse-plugins-2.30.1-1.fc14
rating: 4
reason: Process /usr/lib64/seahorse/seahorse-applet was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Rawhide)

How to reproduce
-----
1. Believe I got this on system shutdown: I just did System->Shut Down
2.
3.
Comment 1 Tom London 2010-06-07 09:42:39 EDT
Created attachment 421827 [details]
File: backtrace
Comment 2 Bug Zapper 2010-07-30 08:03:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthias Clasen 2010-09-03 13:15:49 EDT
Filed upstream: https://bugzilla.gnome.org/show_bug.cgi?id=628720
Comment 4 Fedora Update System 2010-09-03 15:53:25 EDT
seahorse-plugins-2.30.1-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/seahorse-plugins-2.30.1-4.fc14
Comment 5 Fedora Update System 2010-09-03 18:37:32 EDT
seahorse-plugins-2.30.1-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update seahorse-plugins'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/seahorse-plugins-2.30.1-4.fc14
Comment 6 Tom London 2010-09-07 10:13:28 EDT
I believe I'm continuing to see this segfault with the rawhide package: seahorse-plugins-2.30.1-4.fc15.x86_64

I updated to these version on 3 Sept and got this crash on 5 Sept:

Core was generated by `/usr/lib64/seahorse/seahorse-applet --oaf-activate-iid=OAFIID:GNOME_SeahorseApp'.
Program terminated with signal 11, Segmentation fault.
#0  handle_clipboard_owner_change (clipboard=0x1cbe0a0, 
    event=<value optimized out>, sapplet=0x1d16090) at seahorse-applet.c:257
257	    priv->board = clipboard; 
Missing separate debuginfos, use: debuginfo-install dbus-libs-1.4.0-1.fc15.x86_64 pixman-0.19.2-1.fc15.x86_64
(gdb) bt full
#0  handle_clipboard_owner_change (clipboard=0x1cbe0a0, 
    event=<value optimized out>, sapplet=0x1d16090) at seahorse-applet.c:257
        priv = 0x0
#1  0x00000038ad40e93e in g_closure_invoke (closure=0x1d2f530, 
    return_value=0x0, n_param_values=2, param_values=0x1d59640, 
    invocation_hint=0x7fff4f64a2e0) at gclosure.c:766
        marshal = <value optimized out>
        marshal_data = <value optimized out>
        in_marshal = <value optimized out>
        __PRETTY_FUNCTION__ = "g_closure_invoke"
#2  0x00000038ad42043b in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=0, instance=0x1cbe0a0, emission_return=0x0, 
    instance_and_params=0x1d59640) at gsignal.c:3252
        tmp = <value optimized out>
        handler = 0x1d1f270
Comment 7 Fedora Update System 2010-09-14 00:57:27 EDT
seahorse-plugins-2.30.1-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Tomáš Bžatek 2011-01-17 05:49:57 EST
(In reply to comment #6)
> I believe I'm continuing to see this segfault with the rawhide package:
> seahorse-plugins-2.30.1-4.fc15.x86_64
Yes, because the patch has been accidentally left out, not applied.
Comment 9 Fedora Update System 2011-01-17 06:13:39 EST
seahorse-plugins-2.30.1-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/seahorse-plugins-2.30.1-5.fc14
Comment 10 Fedora Update System 2011-01-25 16:00:43 EST
seahorse-plugins-2.30.1-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.